New install of Local 2.0.6 gets stuck at "Waiting for an IP" on Windows 8.1


I’m trying to install Local on my laptop since yesterday. But it’s have no progress until now. When I see the log file, it’s stuck at “Waiting for an IP” process. And have this following error while waiting for it finish.

After get that error message, I wait for another hours but has no progress.

I already try:

  • Closing Local and then lauch the installer again still lead me to “Waiting for an IP”.
  • Uninstall then reinstall didn’t solve the issue (I already do it for a couple of days now since I’m trying to install older version).
  • Uninstall, then delete all Local folder under AppData/Local and AppData/Roaming, restart my laptop and launch the installer again still not working – stuck at “Waiting for an IP”.

Hope that someone can help me to troubleshoot this. Really looking forward to use Local. :slight_smile:

Additional Info:
Laptop - Win 8.1 x64
Try to install Local 2.0.6

Thank you,

Still not have any answer yet. :frowning:

Hi @eljuno,

Sorry for the delay!

Can you please try upgrading to VirtualBox v5.1.26 and then try re-running Local?

Here’s the link to download the latest version of VirtualBox:

Hi @clay,

Thanks for the reply. Which one that I should download?
VirtualBox 5.1.26 platform packages or VirtualBox 5.1.26 Oracle VM VirtualBox Extension Pack?

And after upgrading VirtualBox, should I only running Local or running the Local installer?

You’ll want the “Windows hosts” version under platform packages. Here’s the direct download link:

After running that you can open Local. You don’t have to run the initial setup.

Hi @clay,

I’ve downloaded the VirtualBox, running it, and it’s upgraded to 5.1.26.
Then I run Local and still no luck. :frowning:

I also restart my machine, then run Local again but have no progress.
Here’s the screenshot

Alos the log file in case you need it.
local-by-flywheel.log (10.8 KB)


Can you please try the following?

  • Go to Control Panel » Network and Internet » Network Connection
  • Right click on VirtualBox Host-Only Network » Properties
  • Enable “VirtualBox NDIS6 Bridged Networking Driver”

Also, do you have VMWare Workstation or any other virtualization software installed?

Hi @clay,

When I check it, it’s already enabled. Both for VirtualBox Host-Only Network and VirtualBox Host-Only Network #2.

I think no.


Thanks for the screenshots!

Have you restarted your computer recently? Sometimes that can resolve some issues with VirtualBox on Windows.

Also, if you don’t have any other important virtual machines in VirtualBox, I would try the following:

  1. Uninstall VirtualBox
  2. Restart your PC
  3. Re-open Local

Thanks for the suggestions, @clay. I’ll do it and get back to you soon. :slight_smile:

Hi @clay,

Here’s an update.

  • I uninstalling Local and VirtualBox
  • Restart my laptop
  • Then try to launch the Local installer again.

At this time I get stuck at “Local Image” process.

Then I close Local after no progress for 3hours+. And here’s what I got from log file after close Local and relaunch.
Aug 21, 2017, 11:11 PM GMT+7 - info: [main/menu] Unable to restart Docker Machine. Aug 21, 2017, 11:13 PM GMT+7 - info: [main/index] Existing Pressmatic data does not exist. Aug 21, 2017, 11:13 PM GMT+7 - warn: [main/index] Unhandled Rejection at: Promise Promise { <rejected> { Error: getaddrinfo ENOTFOUND at errnoException (dns.js:28:10) at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:76:26) code: 'ENOTFOUND', errno: 'ENOTFOUND', syscall: 'getaddrinfo', hostname: '', host: '', port: 443 } } reason: Error: getaddrinfo ENOTFOUND at errnoException (dns.js:28:10) at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:76:26) Aug 21, 2017, 11:13 PM GMT+7 - info: [main/set-docker-env] Getting Docker Machine env. Aug 21, 2017, 11:17 PM GMT+7 - info: [main/set-docker-env] Received Docker Machine env. Aug 21, 2017, 11:17 PM GMT+7 - error: [main/index] TypeError: Cannot read property 'forEach' of null at exports.(anonymous function) (C:\Users\User\AppData\Local\Programs\local-by-flywheel\resources\app.asar\helpers\process-exports-vars.js:1:6081) at C:\Users\User\AppData\Local\Programs\local-by-flywheel\resources\app.asar\main\actions-docker\set-docker-env.js:1:8832 at ChildProcess.exithandler (child_process.js:230:5) at emitTwo (events.js:106:13) at ChildProcess.emit (events.js:191:7) at maybeClose (internal/child_process.js:885:16) at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)

hey body
this is exactly my issues but in the win10
why they don’t answer we?!:tired_face:

hi clay
i’ve that issue exaxtly
also i’ve VMware machine
can u help me plz?
i sent u msg but untill now not answered :sweat:


Thanks for the log!

Can you please try opening Cmd.exe and running the following?

C:\Users\User\AppData\Local\Programs\local-by-flywheel\resources\extraResources\virtual-machine\vendor\docker\windows\docker-machine.exe restart local-by-flywheel

And then:

C:\Users\User\AppData\Local\Programs\local-by-flywheel\resources\extraResources\virtual-machine\vendor\docker\windows\docker-machine.exe env local-by-flywheel

Hi @clay,

Should I running it on different cmd? Or need to finish the first one and then running the second one?

  • I open cmd.exe via Windows Key+R > cmd.
  • Type the first one (actually I copy paste)
  • Running
  • Then get stuck at Waiting for an IP

Here’s the screenshot

Since it’s not finish, I can’t type and running the second one. :confused:

Get these lines on cmd (same like in the log file) after waiting for an IP is “finish”
Maximum number of retries (5) exceeded

Then tried the second one and get something like this (forget to screenshot)
An existing connection was forcibly closed by the remote host.