Local Community

New version of Local (6.7.1+6369) breaks terminal

Issue Summary

I was a user affected by the issue with Terminal not working in previous versions; I installed iTerm as a workaround. With the new version, clicking “open site shell” now doesn’t do anything (I tried uninstalling iTerm and reinstalling it, and can’t seem to get the button to work now regardless).

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

1 Like

UPDATE: I forgot that Local itself has an option for which is the default terminal to use. I updated that and it now works fine.

Hey @redblue - I’m glad you got it fixed! Was the issue that iTerm wasn’t installed? Or when you say I updated that and now it works fine - assuming “that” is the Local terminal default, what did you set it to?

I simply changed the Local option from using iTerm to using the default terminal.

While the default Terminal.app now works with Open Site Shell it no longer works with iTerm. I have both installed and change the default terminal app to test.

Thanks for the confirmation! (I don’t mind that it doesn’t work with iTerm; I just care that one of them works).

Argh, ACK - missed a line in the fix for the OSA script that powers this now. Have a fix merged already, and will get that out ASAP. Thanks for confirming!


On Ubuntu 20.04 terminal is broken with local-6.7.1-linux.deb just now downloaded.

Commands for update:

victor@victorpc:Local$ sudo dpkg -i local-6.7.1-linux.deb 
(Reading database ... 447014 files and directories currently installed.)
Preparing to unpack local-6.7.1-linux.deb ...
Unpacking local (6.7.1-20230424.4) over (6.7.0-20230315.3) ...
Setting up local (6.7.1-20230424.4) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for mime-support (3.64ubuntu1) ...

Error message:

There was an error creating the child process for this terminal
Failed to execute child process “/home/victor/.config/Local/ssh-entry/nf_r4obez.sh” (Permission denied)

Any work-around will be greatly appreciated (it’s essential to start terminal this way to get wp-cli commands, etc.).

BTW if I go back to 6.7.0-20230315.3 the problem disappears

I’ve faced the same problem today; glad to hear that there’s a fix coming soon :+1:


I’m having the same issue, running v6.7.2+6369 on Ubuntu 22.04.2 LTS. My specific error message is:

There was an error creating the child process for this terminal
Failed to execute child process "/home/robert/.config/Local/ssh-entry/ZGJhtAn6b.sh": Failed to execve: Permission denied

Interestingly, when I view the contents of that folder, all the .sh files are executable except for the ones that I try to open the site shell for. Also, trying to run the site shell for a new site will unset the permission. Steps to reproduce:

  1. Pick a site that you haven’t run site shell on since the update (or create a new site if you need to)
  2. Note the connection detail on the Database tab of Local. It should be 9 characters long. (In my example above, it’s ZGJhtAn6b.)
  3. Run ls -la on ~/.config/Local/ssh-entry/, and note that ZGJhtAn6b.sh (substituting in whatever yours is) is executable.
  4. Go back to Local and try to run site shell on that site. Terminal will open but will have the error message above.
  5. Run ls -la again in that directory. You’ll see that ZGJhtAn6b.sh is no longer executable.

I’m not seeing anything likely in Local’s logs or its router logs, but I can provide them if needed.

As a side note, you can work around the issue if you chmod +x the shell file and then run it. The shell opens properly and you get access to WP CLI, et al.

Using my example above, I:

  1. chmod +x ZGJhtAn6b.sh to add the executable flag back to it.
  2. ./ZGJhtAn6b.sh to run it.
  3. My working directory changed to the path of the /app/public for the site, and I was able to run WP CLI commands, mysql commands, etc.
  4. That script was running as a process, so exit brought me back to ~/.config/Local/ssh-entry.
1 Like

Hey all, just doing some cleanup - I moved this out of the “Support” category and into “Bugs” to make it more visible for people searching for the issue.

Good news, the issue is fixed and released to Beta - it should be out to stable very soon. If anyone who was running into it wants to try Beta and let us know if you still see issues, that’d be great!

Regression seems fixed for Apple Silicon Local Beta v6.7.2


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.