No https (SSL) on Windows 10 PRO

Issue Summary

Browser say: Connection is not secured (no SSL)

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Not on all sites, just on new sites

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Yes, with the problem.


  1. Generate new site
  2. Request SSL (click trust)
  3. After “trusted” notification: open site (using local)
    Boom, no https, just http

System Details

  • Which version of Local is being used? - 6.6.0+6231

  • What Operating System (OS) and OS version is being used? - Windows 10 Pro

  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @mulli We have some troubleshooting steps lower down in this help article to help you try and resolve this: SSL in Local - Local

If you’re still having problems let us know what you’ve tried and we can go from there!

Hi Nick, more info

  1. I get INVALID certificate
  2. Disabled my ESET antivirus - did not help
  3. I have 2 locations, both same version - I do not know which one is used & if it matters (seems identical)

I must have the SSL for the SW that I am developing & testing
My current bypass is HTTPS->HTTP using site adminer (options table)

Please advise - T H A N K S!

Can it be a conflict with ESET antivirus?

Hi @mulli

It’s possible it’s still an issue with the antivirus. You could check here for some more help:

Do you have any other developer applications that you are also running with Local? Like XAMPP, etc

hi @Nick-B
Thanks for your quick response.

  1. Unchecking the read only on /etc/hosts - did not make a difference.
    Even on new trusted default site - I get connection insecure (latest Chrome fro Win 10)
    Moreover, in adminer: wp_options contain https for the website
  2. No, no xampp (or other) installed

Please also note that out of ~15 sites, 5 has valid SSL, others (newer ones) do not.
I am sure its an integration issue, most likely not Local bug, but still, it prevents Local
from providing the so-good service …
I hope you have more ideas - I am here to cooperate & help

Hi @mulli have you been through any of the workarounds and troubleshooting steps from this common thread over here?

Hey @Nick-B Thanks for asking. In short: yes & no.
Yes, I can put “thisisunsafe” into chrome and somehow the domain (I do it my in my dev. env only) is in some Chrome’s white list.

However, this is ugly (and not safe), and all my new sites are not using SSL as they should
Which also limits my work (e.g. interfacing with app’s that require SSL).

So NO - I am still stuch & unable to create SSL’ed websites

I check for news on the issue every fey days.

FYI - I’m getting the same issue. Local 6.6.0+6231 on Windows 10 Pro.

SSLs don’t work anymore. Existing sites work.

No matter what I do the SSL will not be accepted by chrome and firefox.

Edge browser accepts the certification without an issue.

For Firefox and Chrome VS edge may help people who know much more than me Debug this problem.


1 Like

I use “thisisunsafe” which bypass the SSL issue in Chrome see for more details

Hoever, debugging with Vscode is not working for me.

I dont even get that option on Chrome anymore. Its completely blocked and that feature is no longer available.

Not sure I can help… but here is another link to bypass the SSL.
In short, Chrome will add your domain to some “ignore ssl” whitelist that it manages.

Also an ESET user here who’s locked into it staying on for company reasons, and I do think there’s some conflict between ESET and Local’s generated certificates that’s causing issues, but I still haven’t been able to narrow it down any further. I tried deleting Local’s certs in certmgr, temporarily disabling ESET, then generating the new certs and it gave me different behavior but ultimately still did not resolve it completely. I recreated my dev environment on my personal machine and it didn’t experience the issues at all there, so I’m near-certain it’s ESET.

Independently (I think), if you check any website with a Let’s Encrypt cert (including sites hosted on Flywheel), ESET reports it as the parent of that cert, which has got to mean it’s scanning it and messing with it in some way, but I’m no ESET expert.

@mulli I use ESET NOD32 and do see a similar issue in Chrome. I do most development with Firefox, which isn’t impacted.

I just loaded Chrome and tried to open a .local site, and received the invalid cert message. I used the “disable protection” option from the NOD32 systray icon, restarted Chrome and tried the site again – same result. After re-enabling the protection, I then went into the NOD32 settings and disabled SSL filtering (per [KB3126] Disable SSL filtering in ESET Windows home products (14.x–16.x)), restarted Chrome, and the site came up as expected. I suspect that disabling protection with the systray option is not disabling SSL filtering.

I don’t see an obvious way to exclude *.local domains from SSL filtering. The “exclude communication from trusted domains” option on that settings page indicates an internal whitelist/allowlist – I don’t see an obvious way to add to that list.

I also tried exporting the Local cert and importing it – click edit on “List of known certificates” on that settings page – but the cert didn’t appear to fully import (possibly due to missing corresponding CA cert?).

You may want to ask some questions of ESET technical support to see if there are any options to exclude the .local domains, or consider the Local cert as valid (likely by a successful import).

Hope this helps.


how to fix thos error windows 10

Hi @amiin

I’m not sure that what you’re seeing is related to this post/thread.

Could you create a new post and include your OS, Local version, and Local Logs? Retrieving Local’s Log File

@burt HUGE Thanks for your response. Recently I did the following:

  1. removed (complete uninstall) ESET
  2. recreated certificated (delete & generate) - on few domains (since some certificates are ok!)
  3. tried generating new sites with fresh SSL certificate.
    Test: 2,3 fail to generate valid SSL

I am not sure if ESET causes the issue. Since I can regenerate the problem w/o it.
I can only recall that at some point (~ nov, 2022) the problem began.
So i have the old domains with valid SSL cert. but all new domains without.

1 Like

I can confirm that following the steps to disable the “Enable SSL/TLS protocol filtering” setting in Advanced Settings worked like a charm and let me right back in! Thank you much for this post, burt.


@burt, @lcraft
Finally reinstalled ESET, disabled the SSL filter option
and everything works as expected.
THANKS for great help


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.