OSx Catalina Uh-oh! unable to provision site

I have looked for other tipics that might helped, I did not found that could help me solve my situation. my install localwp and try to add new site but I got a return error: “Uh-oh! unable to provision site” detail will be provide in the log file.

OS: osx Catalina

Local Version: 5.2.4 +2399

local-lightning.log (148.1 KB)

I saw the following in your log.

[Server] The socket file path is too long (> 103): /Volumes/Documents/Users/Atipat Lorwongam/Library/Application Support/Local/run/pL3W8-_Jr/mysql/mysqld.sock","timestamp":"2020-02-14T20:30:56.963Z"}

I wasn’t aware there was a file path character limit.

Possibly related https://unix.stackexchange.com/questions/367008/why-is-socket-path-length-limited-to-a-hundred-chars

It looks like you have the Local app on an external drive. Moving to your boot drive should shave off enough characters from the socket path to work.

I tried to change file path, and that doesn’t help. I still have this problem, I’ll show you the whole error popup, in the attachment.

Is any part of Local or your site on an external drive?

no. only in another partition

Can you try putting everything on the same partition, preferably the main partition.

I tried manually selected site path, a minute ago, no help

here is new log file.

local-lightning.log (172.9 KB)

I still see the same error.

{“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2020-02-15T00:12:49.512121Z 0 [ERROR] [MY-010267] [Server] The socket file path is too long (> 103): /Volumes/Documents/Users/Atipat Lorwongam/Library/Application Support/Local/run/MQb4Tdd1T/mysql/mysqld.sock”,“timestamp”:“2020-02-15T00:12:49.513Z”}

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.