Problem ZIP file isn't compatible

What issue or error are you experiencing?

I tried to export my site in Local by importing zip file from WP Migrate Lite and an error occured : ‘try to import compatible ZIP file’ .
I found a lot of subject about it on the Local Community, and they all say that it’s the other files or Wordpress Core Files boxes that contain certains type of files like backup wich make the import fail,
so i followed every steps i saw here :

  • export only database(.sql) and wp-content file
  • try to import it manually
    but nothing occured , i still get the same error message with ZIP compatibility.

I really tried many combination of export : only the DB and medias , only DB and plugin, only DB and theme , DB medias and theme only , every time it’s the same , import run until the really end and then start to delete the local files with the error message.

I don’t know what file are not supposed to be in the extract file, i give you screen of my export set up

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

my ZIP file :

My export Setup :

System Details

  • Local Version:
    Local Version 7.1.0+6396
  • Operating System (OS) and OS version:
    Windows 10
    PHP Version 5.6.4
    Web server Apache 2.4.43
    Database MySQL5.7

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-lightning.log (53.3 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @louisf

Does it work if you switch the server to NGINX?

As a manual workaround, can you try the steps below?

  • Unzip the file in a common location, like the desktop
  • Create a new, blank site in Local. Use whatever username/password you like since you’ll overwrite the DB with this site archive’s dump.
  • Copy the wp-content folder from the unzipped location to this newly created site’s location
  • Copy the correct SQL dump to the site root.
  • Within Local, open the site shell
  • Import the dump with wp db import <dumpfile>
  • If that works, now Search and replace the domains. wp search-replace ' ' 'http:mylocalsite.local'

I just spend the 2 last days try everything i can to import manually my multisite , just thank you @Nick-B

Changing the web server to nginx seems to work perfectly my all website and all his subdirectory are correctly imported despite the local overview say “Multisite : no”. I don’t kow why just changing the web server could impact the import this mutch but i leterally never seen this answer in any post related to the subject , its very strange !

Anyway i really thank you for ur fast answer love to see that the support is reactive :smiley:
see ya next time

1 Like


I didn’t realize you were trying to import a multisite, in the future you might find this helpful on working with multisites with Local. They generally require a bit more manual work for importing/exporting.

Yeah unfortunatly i saw this article but i didn’t found the solution here ,
All is working well , but just one question , when you import from zip file Local don’t ask u to create account for wordpress (id and password) so i assumed that i had to log with my credentials from my live website but it didn’t work , and it created itself an new user id : “Cdt78ve_root” in my case. Do you know where i can find the password who rely to the wp-admin account ?

You won’t be able to see the password but you can Open Site Shell and use wp user list to view the current list of users/admins.

Using steps from this help article you can always create/reset/edit passwords for new or existing users:

Ye ok i figure it out , was my bad ! thanks a lot you help me so much here !

1 Like

Of course! Glad you got things working. Happy Developing :green_heart:

Hey there @Nick-B ,
Sorry to disturb you again , just after we talk and successfully import my website locally with no issues, i run into the WP Admin section to start my work but something occured that i don’t know how to handle (sorry if the answer is obvious, i just started to work with those environnement recently :smiley: )
So when i clicked on the WP Admin button he instantly ask me to updated wordpress database for the newest version with a page that i cannot skip and only one button → “update” , so i did it and after that i wsn’t allowed to acces the mysite.local/wp-amin page , send me everytime an error 403 and the message : “sorry you havn’t authorization to acces this page”, i saw that it could be the user’s role changes into something else but administrator but no my user still got that admin role.
I tried to create new user with admin role by the WP CLI , successfully added one with admin role but still … don’t have acces to the WP panel.
Enabled the One-click admin section didn’t help me neither , all of the different admin user i choose have the same redirection “not authorized”
I don’t know where to look now , i could use some help to find a solution i’m a little lost by myself here
Thanks a lot

Are there any security plugins on the site? Or user management plugins? You could try deactivating those or all of the plugins on the site via WP-CLI. It might be that something is locking you out.

Ye i tried to desactivate all , but same error i’m still not authorized

Wp-admin page :

If you change your Router Mode to Localhost are you able to get in? Preferences>Advanced>Router Mode

i put router mode on localhost , It fixed the fact that i can access the wp-admin page and try to connect , but when i put user and password → same i’m connected to admin but not authorized ,
also Local application display this warning message :

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.