Migration/cloning issue

Hi, when I export my LocalWP site (using the export site feature) and try to import it onto another PC with LocalWP (via drag and drop), it says that the ZIP file is not compatible. I’ve also attempted to follow these steps here: Import/Export a WordPress Site - Local with no success. After completing the migration, the page does not appear the same as mine; it looks broken. It’s strange because the WordPress edit page looks fine, but when I visit the default URL, it’s broken. Does anyone know how to successfully import a LocalWP site using the export feature? Or do you have a comprehensive guide for importing and exporting, apart from the official post? Thanks for reading.

Hi @joaquinzub!

One thing you can try is unzipping the backup file and pulling out just the WP-Content and SQL files and bundling those together in their own zip file. Once you have that new zip ready you can try dragging and dropping that into Local.

We’ve been exploring options for making this easier like this feature request for example:

Keep us posted if you’re still having trouble!

Hi Nick, yes, I’m still experiencing the issue. I followed your instructions exactly, but it keeps saying that the ZIP file is not compatible. By following these steps Import/Export a WordPress Site - Local, the ZIP file ended up like this

This is the structure of the ZIP file. If you need any additional information to provide more context, please let me know. Thank you for your reply!

The ai1wm-backups is likely the issue. Could you try removing that and then zipping it up and importing again?

Yes, I’ve tried it with no luck. It keeps saying that the ZIP file is not compatible. I also tried deleting every folder to follow this path:
with no result.

You could attempt a more manual import. The steps would look like this:

  • Unzip the file in a common location, like the desktop
  • Create a new, blank site in Local. Use whatever username/password you like since you’ll overwrite the DB with this site archive’s dump.
  • Copy the wp-content folder from the unzipped location to this newly created site’s location
  • Copy the correct SQL dump to the site root.
  • Within Local, open the site shell
  • Import the dump with wp db import <dumpfile>
  • If that works, now Search and replace the domains. wp search-replace ' https://production.com ' 'http:mylocalsite.local'

Hi Nick, I apologize for my delayed response. I followed all your instructions, but unfortunately, I didn’t get the desired result. However, not to worry, I managed to resolve the issue by copying all the files and setting up a local WordPress installation using XAMPP, and it worked perfectly.

But now, I’m facing a similar problem when it comes to importing, exporting, or cloning the site. The page appears broken, with images displaying excessively large, unusual styles, and a broken navigation block. I’ve already taken several troubleshooting steps, such as disabling all plugins, reinstalling WordPress, and using the default Twenty Twenty-Two template (which I was originally using), and using migration plugins but I couldn’t find a solution.

I’m not sure if this issue belongs to this forum, but I would greatly appreciate any assistance or insights you can provide. Thank you for taking the time to read this.

Here are some images that illustrate the error. I’ll attach them below
This is the bug:

It should look like this

I think what you’re running into is a known bug with WordPress 6.3.

We have a thread going here with some workarounds:

Dude, you’re a lifesaver! Thank you so much. Do you know if I need to delete the define('WP_DEVELOPMENT_MODE', 'all'); code when I deploy my website to a hosting service?

It might depend on your host. Some won’t allow you to edit that once your site is on their platform. So I’d check with them and find out if you’ll be able to make changes once it’s moved. That might help you decide what to do next.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.