Importing wordpress zip file

I used WP Migrate to Export a zip file of my wordpress site. But Local is saying my zip file is incompatible.

Troubleshooting Questions

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used? Version 6.6.1+6281

  • What Operating System (OS) and OS version is being used?

    • Windows 10 Professional_
  • Attach the Local Log. See this Help Doc for instructions on how to do so: (2.1 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @justine.m.ferrell

Another user over here was running into the same issue recently:

Can you see if your backup is including any unnecessary files?

Hi @Nick-B,

Based on that thread - I should not be doing a full backup? What shouldn’t I be exporting?


Hi @justine.m.ferrell

Based on your screenshots, what might be the problem is the box Other. I can see within the breakdown that ai1wm-backups are included. If there are backup copies of the site saved within the site files that could be causing the zip to be incompatible. To put it simply all Local needs to import a site is a wp-content folder and a SQL file. When extra backup files are included this can cause issues for the import because of the duplication of directories. Additionally, storing backup files on your site is rarely a good idea for optimization since it can cause overall bloat and performance problems. It’s always best to offload these to other storage options like Dropbox or Google Drive.


I just wanted to report that I experienced this same issue with Flywheel backups today.

Unzipping the backup and removing everything except for the database (.sql file) and the wp-content file and then zipping the file again and importing it to Local did the trick.

I just wanted to let you know so you’re aware, and I’m happy to provide any info (local logs, etc) if it’ll give you further data to help troubleshoot.

Thank you for following up @vivacami! I actually was looking at your support ticket this morning. I tested doing a Local Connect pull of your site and curiously that worked without issue! If I do the download and import method however I get the same error message you saw. I don’t see any backup or database files in your zip so we are still trying to drill down what might be causing that import error and will let you know what we find!

1 Like

@Nick-B @vivacami
Thank you for the support! If I delete all this extra stuff - will I have difficulties pushing changes to the live WordPress site?

Hi @justine.m.ferrell Any changes you have will be the wp-content and database files, so you shouldn’t have any difficulty. If you’re worried about something you need going missing just retain copies of your exported site or the specific files so you always have them just in case.

I am also having issues importing sites to Local. I am using Local files from a Time Machine backup. Tried zip of entire site and also just wp-content and sql file. Error is always saying that zip file is incompatible.

Hi @Dex

You could attempt a more manual import. The steps would look like this:

  • Unzip the file in a common location, like the desktop
  • Create a new, blank site in Local. Use whatever username/password you like since you’ll overwrite the DB with this site archive’s dump.
  • Copy the wp-content folder from the unzipped location to this newly created site’s location
  • Copy the correct SQL dump to the site root.
  • Within Local, open the site shell
  • Import the dump with wp db import <dumpfile>
  • If that works, now Search and replace the domains. wp search-replace ' ' 'http:mylocalsite.local'

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.