Pulling from WPEngine doesn’t work

Bug Summary

When attempting to pull from WP Engine I cannot pull any files or Database. It was working properly then all of a sudden this error kept popping up when trying to pull down files and/or the database.

I even added a new SSH Key to my WP Engine profile and the error still is happening.

Environment Info

Describe your environment.

  • What Operating System are you using?
    MacOs Monterey
  • What versions of site software (Nginx, Apache, PHP, MySQL) is used?
    I am using LocalWP
  • What version of Local is installed?
    Version 6.1.8+5621

Supporting info

Please provide your Local Log. See this Community Forum post for instructions on how to do so:

local-lightning.log (268.0 KB)

Can someone help here?

Hey @consensusb

I’ve moved this topic to the “Support” category since the “Bug” category is more for wide-spread, reproducible issues – Let’s see what’s going on and how we can help you!

Taking a look at the Local log, I’m seeing a few lines that make me think that the SSH connection isn’t working as expected:

{"thread":"main","class":"DevKitService","message":"Warning: Identity file %%userDataPath%%/ssh/wpe-connect not accessible: No such file or directory.\n","level":"warn","timestamp":"2022-01-10T21:30:47.548Z"}
{"thread":"main","class":"DevKitService","message":"wpe_cli+rsync+pull+lifescisrchpro@lifescisrchpro.ssh.wpengine.net: Permission denied (publickey).\r\n","level":"warn","timestamp":"2022-01-10T21:30:48.206Z"}
{"thread":"main","class":"DevKitService","message":"rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]\nrsync error: unexplained error (code 255) at io.c(226) [Receiver=3.1.3]\n","level":"warn","timestamp":"2022-01-10T21:30:48.208Z"}
{"thread":"main","class":"DevKitService","message":"Warning: Identity file %%userDataPath%%/ssh/wpe-connect not accessible: No such file or directory.\n","level":"warn","timestamp":"2022-01-10T21:31:04.029Z"}
{"thread":"main","class":"DevKitService","message":"wpe_cli+db+pull+lifescisrchpro@lifescisrchpro.ssh.wpengine.net: Permission denied (publickey).\r\n","level":"warn","timestamp":"2022-01-10T21:31:04.443Z"}

Can you try disconnecting Local from WP Engine and then re-connecting?

If you still have issues, then maybe there’s a problem with the permissions of the .ssh folder? Here’s what my folder looks like, though you might have different files:

Thanks Ben.

I did a few things and I’m not sure what fixed it.

  1. I created a new SSH Key and added the new key to my WP Engine account.
  2. Then, I disconnected LocalWP and connected again to WP Engine with a new API key.
  3. Then, I adjusted my ssh folder and file permissions.
  4. Restarted LocalWP and this seemed to work.

Putting this here in case anyone in the future has the same issue.

1 Like

I had the same issue today and simply generated new API creds on WPEngine, disconnected then reconnected to WPEngine in Local with the new creds, and that worked.


This topic was automatically closed after 730 days. New replies are no longer allowed.