Re-importing a site

I had some trouble with Local not working, so I had to re-install it from square 1.
Local is now working fine, but not recognizing any of my previous sites I had in there.

I created a new site and tried to overwrite everything with an old Local site, but none of this is working.

Is there any way I can re-import a site?
I have the folders with public and SQL, but I can’t do a regular import because the database is not a single database.sql file, I guess…?

I really need the previously created site to work again: i can’t redo all the work I put into that.
Any help?

Just to be clear I have a folder from the site, with these subfolders


all wordpress files are in app>public and all sql files are in app>sql

So the question is: how do I get this to work again in my new install of Local?

Hi Steven,

I just added this FAQ: How can I restore a site from a Local site folder?

Please let me know how it works for you :slight_smile:

hello, I am also trying to restore my local websites after a computer issue. I did exactly what the FAQ said but when I enter the text (myloader -p root -d /app/sql --overwrite-tables --database local) SSH, I get this error:
** (myloader:338): CRITICAL **: the specified directory is not a mydumper backup

I am not advanced in this sort of thing but I assuming the directory is wrong. Could you please help. My Local sites folder is in my home directory on my Mac running Sierra 10.12.6

I just tried putting the line of code in a plain text file and then pasting into SSH and now I am getting the error:
bash: -p: command not found

Hi JPS, I have similar issues. Did you find a solution ? Thanks!

Hi Steven,
I have similar issues. I changed my hard drive into an SSD drive and I copied the local sites file. I tried to follow the procedure recommended by Clay but it did not work…
Any advice on your side ? Thanks a lot…