Local Community

Rebuild Site after crash

Issue Summary

When my system crashed everything what left is a backup of the “Local Sites” folder where two sites are included.
I made zip-files from the two folders and tried to import them via local.
I went to the import-procedure `til local promted “local is requesting administrative priveliges to modify file under etc/host/…”
When I entered my password the procedure went on but stopped and showed me "Uh-oh! Unable to import site. / Error: Local was unable to import the following SQL files:
There are no sql files listed wich are missing.

What can I do or try to get my sites back?

I would be more than happy to receive any help or hint

best

Kai

Hi @77of99

Can you create a fresh new site in Local and get in to it?

Have you looked inside the folders you zipped up to see what is in there? Is it all of the site files or only partially recovered ones?

For future projects, we have Cloud Backups which you can use for free to connect to Dropbox or Google. We highly recommend saving all work this way: Cloud Backups - Local

Yes, I can build a new Site in Local.

The zip-folder contains the whole site files.

Is there any chance to get it back?

Bets
Kai

Hi @77of99

In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Try and import again. If you’re still having trouble can you send us an updated Local Log? Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

Hi Nick-B,

thanks a lot for your help!
I uninstalled Local and installed the latest version, restarted the computer and closed any background activity I found.
Then I tried again to import the site.
Sadly it failed again.
I attach the error log and hope that you can find something wich will help to solve my problem.

thx in advance

best

Kai
local-lightning.log (24.1 KB)

I made a video about what happens when trying to import the site (I am not able to upload the file - seems that .mp4-files are blocked).
If somebody is able to fix my problem I would pay for it!
Please give me an offer.