Looks like you haven't created a site yet


I was importing a site but it was stucked, so I have closed Local.
When I open it, all sites seems lost and it is saying “looks like you have’nt creates a site yet”.
Files are intact but Local can’t display the sites in dashboard.
What should be done?


See the “Restoring From Only Local Site files” section for how to re-import your sites

I have tried that…
Some sites can be restored by image problems.
Some sites throwed an error with sql.
Some sites throwed Enoent error.

I dont know what to do. It is very strange that “Local” cannot display the sites there was no change.

It is weird that no one can comment on this.
Does anyone there thinks that local should scan and find the related sites?
It looks like a major collapse for a digital product.

It is weird that no one is replying for 5 days.
This product, “Local”, is on its own? Is it a loose end?
No team, person, owner behind it?

It seems “Local” is not owned by anyone.

Local is owned by WP Engine, and there is a WPE moderator but I’m not sure who that is.

This is a community support group and we all have day jobs.

What I gather from your problem statement is that you have a botched site import and local never finished setting up the site it was importing.

A couple of thoughts;

  • Have you setup a new site without importing to confirm that your installation of Local is working?

  • Where/what are you importing from?

Ah thank you Mikel.
Yes, this is a community forum but in past, I have seen Local Community Managers replied to posts. I thought they were appointed by Local. Maybe that was a mistake.

  1. Setup new site is working.
  2. I was importing a zip file and Local was stucked. Then I have restarted Local, when I reopened it, it said “Looks like you haven’t created any sites yet”, but the files of the sites I have created was there, intact. I tried zip them and import. Some of them worked, some of them throwed error.

That’s the actual case, right now.

Break down import zip to simplest components.

wp-content folder and mysql database. Zip those 2 together and drop on Local to import. Making this as simple as possible without any extraneous folders, etc has always worked for me.

Thank you @afragen.
I have tried one site with a method as you mentioned, it throwed the same error:

“Uh-oh! Unable to import site.
Local was unable to import following SQL files:”

No file listed actually.

Thank you so far.
I guess I will stop using Local. It is not trustable.

That error would indicate that you didn’t include the .sql file in your zip.

Would you care to share the files or zip you used?

Thank you @afragen, if it is time consuming for you we can stop this conversation.

There is only one file in mysql folder in every single I have created on Local which is called my.cnf.bhs
So, I have zipped wp-content and this file together.
I cannot upload the zip file of it because of the upload limit, that’s why I am adding sql file zipped.

my.cnf.zip (524 Bytes)

@Volkan my.cnf.hbs is not the database file. You will find the database file in the /app/sql/local.sql inside of each site’s app/ folder. It’s at the same level as app/public/.

Local should automatically create this file as a backup each time you stop your site.

The actual database files are in the Local/run/<hash> folder for each site. On my Mac this is in the ~/Library/Local/run/...

Yes, I know that was not an sql file but I thought Local is using this file as sql file.
Sorry for the misunderstanding.

I will try with the real database file now.

@afragen, thank you again.

I will stop trying to re-create the sites that were existing on Local - anytime soon.
It became such a time spending effort for me and you. I decided to communicate with my clients and ask for the access to the actual site. Then I will update changes from scratch that I have performed earlier on Local.

the SQL folder is populated whenever sites are Stopped or Restarted

Eww! I didn’t know that. And I have never seen sql folder in app folder. Never.
Until I start & stop the site and check the folder now. Yes indeed, a folder called sql popped up.

Well, I copied the sites to new location when Local said “you haven’t created any sites yet”.
I am checking now and none have sql folder in app folder.
And, I have scanned entire disk for sql files, none found (only except the ones I created after Local crushed).

I am a Win 10 user but I really dont know where Local/run folder.
Sorry if this looks stupid but I am really surprised with the sql folder populated in app folder.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.