Regenerating Machine Certificates

Any help on how to get past this problem would be greatly appreciated.

I successfully downloaded Local and launched it. I added a new theme to WordPress and several plugins. As I was adding a plugin, my machine froze. I had to force a reboot. Now, when I launch Local I repeatedly get this message. “Regenerating Machine Certificates. Local detected invalid Docker Machine TLS certificates and is fixing them now.” Local tries and tries to fix them, but isn’t successful. The message just keeps appearing every few seconds.

Sorry for the trouble!

Did you have VirtualBox installed prior to installing Local? If so, do you know what version you have?

Also, can you provide the log for Local? You can find it by going to Help » Reveal Local’s Log. If you’re worried about sensitive data (mainly site names) in it you can e-mail it to and I’ll take a look at it.


I did not have Virtual Box installed. However, maybe this is playing a role. I downloaded Desktop Server from ServerPress yesterday evening. I was getting ready to start working with that when my co-worker suggested I try Local. Is it possible that somehow one is interfering with the other?

I emailed the log to you. Thanks.

Hey Chris,

ServerPress shouldn’t interfere with it at all (with the exception of trying to have the same domain in both running at the same time).

Are you behind any type of office internet, VPN, proxy or anything where would be interfered with?

I’m not actively running Desktop Server at the same time as Local, and I did create unique domain names in each application.

I was logged in remotely to my work VPN. I logged out and successfully launched Local. I had to try several times before I was successful. It frequently got stuck on Starting Local Machine… “Stuck” means that after three or four minutes, Local is still starting. The Regenerating Machine Certificates messages didn’t occur.

Now that I’m in again, I cannot access my site via the Admin button or the View Site button.

Okay, cool. I’ll look into a safeguard for that.

Can you try creating a new site now that the certificate issue is addressed?

I deleted the original site and created a a new one. Everything seems to be working fine now. Thanks for your help.

I got this error quite a few times also, back when Local was Pressmatic, and coincidentally just a few minutes ago, using Local (i.e. V 1.3).

In my case it always happened when one Local virtual server was unable to (fully) shutdown: Pressmatic or Local shows a “Welcome to Local” screen, as if it was newly installed, and there’s the “Regenerating Machine Certificates” warning.

I simply shut down Local immediately, restart it, and everything is back to where it was and should be: all sites still here, no mention of any Certificate problems.

1 Like

I got the same error, but I’m on Windows.
I did not have VirtualBox installed first. As the problem persisted I ended up insatller but still nothing.
Please help!

I’m suddenly receiving the same error, where it is stuck at this screen forever when I start Local:

I tried quitting right away then restarting the app, but then it either crashes, is stuck on “checking system…”, or goes back to trying to fix the certificates again?

Hi Brian,

Can you please try the following in Terminal?

  1. Run vboxmanage controlvm local-by-flywheel poweroff
  2. Run "/Applications/Local by" stop local-by-flywheel
  3. Run "/Applications/Local by" start local-by-flywheel

A full system restart seems to have done the trick! There was also “tripmode” running in the background which may have blocked some network communications.

Thanks for the quick reply!

1 Like

Just wanted to jump in here and say I had this problem just now but after I updated Virtualbox (which I had installed back when I used VVV, before Local) it went away and things returned to normal.

This problem just popped up for me today. I tried updating VirtualBox, a full restart and running the couple Terminal commands to no avail. Running High Sierra 10.13.3.


Please see Regenerating Docker Machine TLS Certificate, checking system won't start

Duplicating my post from:

! ! ! FOUND THE CULPRIT ! ! !  - - Appears OS level VPN needs to be in the same state it was when you installed Local and created your site.

Wow! This is is my 3rd volley throwing a couple hours at this in 3 days - - I was just getting ready to ask for fix commands applicable to a Win10 environment when, HOLD ON - - WAIT FOR IT - Local quit trying to regenerate certs.

WHY? Because I turned my OS VPN off !!!!  THAT fixed the problem. - - If you install Local and create a site with your OS level (not browser) VPN off, THEN later start LOCAL after turning the VPN on, Local will need to regenerate certs 

I reproduced it without rebooting the OS. YEE HAW!!!

Doug Knoyle

@ben.turner  Hope to see you at meetup soon ;)
1 Like