Same domain in Local doesn't let me see my current site online


I have a very simple question, I think…

Currently my website is online and I want to make a new version in Local to upload it to my hosting once it’s ready.

If in Local I put the same domain, when I enter the web browser I can only see the Local version, but I can’t see my real site online.

The same happens, for example, if in Local I want to place any domain. If I put I could see in the browser my website made using Local but not the real website (the banking page in this example).

How could I solve this without having to delete my website from Local? Because, of course, I’d like to work simultaneously on my new website in Local while I’m currently serving customers with my live website.


PS 1: I want to use the same .com domain of my online website and not a .local extension because I want to integrate Stripe in test mode, and Stripe support told me that I can only link one domain. So, if I make requests from another domain I can have problems.

PS 2: I guess there must be some cache that I can clear and have the browser show me the real online version. But it must be something in the OS itself, because all browsers show me the Local version.

Hi @rinco

You’re correct that you’re probably running into caching issues. You could try things like testing in another browser (Firefox, Safari, etc if you’re using Chrome), using incognito windows, using a VPN or LTE data hotspot. Caching can build in up in many places and not just your browser. You could be running into caching problems on your network, or even plugins and themes can sometimes hold caching as well.

It’s interesting that Stripe says you can’t use more than one domain. I haven’t done much testing with them myself but I would imagine a lot of developers if not using Local would still use things like Staging environments before moving to Production. I find it odd they don’t have some other type of workaround to assist with development.

Thank you @Nick-B,

I’ve tried using other browsers and VPN changing IP, but no change.

It must be because when creating the web in Local the black screen of the Windows system appears, and, for example, when deleting the web from Local that screen appears again you can see the original web in the browser.

And yes, Stripe should understand that for testing purposes one is obviously not going to use the same website online, but well…

Have you tried reaching out to Stripe to see if they have any recommended workflows, help articles, guides, etc? I can’t imagine you’re the first user to run into this problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.