Site and Domain Rename issues

On local by flywheel using windows 10. I changed the site and domain name of my website and now It will not open. I receive this on the page.

Hmmm…can’t reach this page

Try this


This might be an issue with Local’s Router. Sometimes other applications can conflict with it and prevent it from starting up.

I recommend trying the following:

  1. Go to Preferences (on Windows, Preferences can be found in the menu in the top-left of Local’s window)

  2. Navigate to Advanced

  3. Set “Router Mode” to “Localhost” and save the change by clicking “Apply”

  4. Try navigating to any running Local site. Restarting the site in Local is sometimes necessary.

It didn’t work. I received the error:

404 Not Found



Considering you renamed the site and changed the domain, did you also relocate any of the files or rename the Local Site’s folder? Local will still be looking for the old path if that’s that case.

I renamed the site and domain back to the original. I found the local site’s folder, but I don’t know if or how I know if local is pointing to it to make sure it is the right spelling. There is always the case I did or didn’t use the spaces. I’ve tried both but I still can’t get it to work. Is there a back end screen that I can manually point everything too?

You can find out what path Local is looking for under the site’s name.


Also, just to make sure I’m suggesting the right things… Does creating a brand new site in Local work? Is it accessible?

This is what I have. It all looks like it should work from what I can see.,

Yes, I’ve created a new site and it worked fine with the old version, but I get an Error establishing a database connection message now

when I create a new site it is stuck on the following screen.


Thanks for all of the screenshots—they’re great.

Can you also send over your local-lightning.log file? Here are details on how to do that: How do I retrieve Local's log file?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.