Site Broken after "Update Environment"

I spend the last few days working on a site to show my bosses in a meeting tomorrow morning. I saw the notice that there was a Local Environment update available. I clicked Update Environment. Cloned the site. I came in today and opened the Clone, and was presented with the “Install Wordpress” screen. Weird. I went back to the old site. It won’t load. Error Establishing Database Connection. Where is the site I spent all week building?

Hey @jrussell

Can you please provide your local-by-flywheel.log file? See
How do I retrieve Local’s log file?” for instructions on how to do so.

Can you also provide a zip of the logs folder for both the original site as well as the cloned site?

– Ben

Always the same answer to questions/issues. Do you even test your software before publishing it? It seems not, or at least not thorough.

And @ben.turner is a “Flywheel Happiness Engineer”. Well, judging by the Community Forum issues posted, there’s not much ‘Happiness’ left…

I’m sorry I haven’t been able to spread the happiness your way! I would love any help or guidance you might have in this area @frizzel77

As for asking for the Local logs – there’s not much we can do without seeing what the actual error is.

– Ben

I’m not comfortable uploading the log file publicly - can I have an email address for you that I can send it to?

@ben.turner Yes you can. By thoroughly testing it on different environments before pushing an “update” with all kinds of new “features” without addressing existing issues. Don’t tell me you cannot see these issues beforehand, because most of them seem not related to a very specific environment. Tons of issues reported on quite normal, standard environments. Just check the Community Forum.

BUMP - I’m not comfortable uploading the log file publicly - can I have an email address for you that I can send it to?

has your issue been resolved as yet? This is my problem if it helps:
I updated my windows 7 machine this morning and after updating, I tried starting flywheel. I was asked if I would like to run as an administrator as usual and I clicked yes. That was all she wrote. I have not even seen the flywheel process in my task manager. I tried restarting the computer, accessing the original .exe file and not the shortcut but nothing works. How can this be resolved?

Hey @jrussell

All of the support for Local is done here on the forums, so there isn’t any email to upload things to.

We don’t include any sensitive information in regards to passwords or emails. Without seeing the log and the actual errors that are being produced, there isn’t much we can do to point in the right direction.

You can always take a look at your local log and search the forums for errors that you might see.

Hope that helps clarify things, if you have any other questions, just let us know!

– Ben

local-by-flywheel - generalized.log (56.4 KB)

Ok - I’ve generalized some of the data in the log. You should still be able to review this and offer assistance.

Bump - can you offer assistance on the log I’ve uploaded?

Hey @jrussell

It looks like there is something that is crashing MySQL which can be seen in this example from the local log:

 Oct 4, 2018, 4:28 PM EDT - error: [main/exportDB]  Error
    at C:\Users\user.domain\AppData\Local\Programs\local-by-flywheel\resources\app.asar\main\actions-sites\wait-for-mysql.js:1:2754
    at (<anonymous>)
    at _0x48423e (C:\Users\user.domain\AppData\Local\Programs\local-by-flywheel\resources\app.asar\main\actions-sites\wait-for-mysql.js:1:1621)
    at Object.wrTIQ (C:\Users\user.domain\AppData\Local\Programs\local-by-flywheel\resources\app.asar\main\actions-sites\wait-for-mysql.js:1:1168)
    at Object.xrPCq (C:\Users\user.domain\AppData\Local\Programs\local-by-flywheel\resources\app.asar\main\actions-sites\wait-for-mysql.js:1:1420)
    at C:\Users\user.domain\AppData\Local\Programs\local-by-flywheel\resources\app.asar\main\actions-sites\wait-for-mysql.js:1:1880
    at <anonymous>
    at process._tickDomainCallback (internal/process/next_tick.js:228:7)

This could be due to any number of reasons, if you do have a zip of the logs folder, we could take a look and see if there is more info in any of those logs for the site itself.

Alternatively, the easiest thing might be to import a backup of the site.

– Ben