Site imported from WPEngine 403's and 404's

Issue Summary

When attempting to run a site that I just pulled from WPEngine I get a 403 or 404 error. Running this site under localhost routing mode worked on my old machine. It doesn’t work under either routing mode on my new machine.

When clicking the Open Site button: 403 Forbidden nginx/1.16.0
When clicking the wp-admin button: 404 Not Found nginx/1.16.0

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

I tried downloading/connecting a second site from WPEngine and the same errors reproduced.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Yes, this works without a problem.


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

Things I tried:

  • Clicked “Trust” next to the SSL details, no change
  • Restarted the computer, no change
  • Under Local → Preferences → Advanced changed routing mode to localhost. No change.

System Details

  • Which version of Local is being used?


  • What Operating System (OS) and OS version is being used?
    • For example: macOS Catalina or Windows 10 Professional

Xubuntu 22.04.1 LTS (784 Bytes)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

I’m seeing these errors as well. app/public/wp_config.php doesn’t seem to exist. The only thing in the public folder is _wpe_private/autoload.sql.

apatters@unimatrix01:~/Local Sites/sacoh/app$ ll
total 4.0K
drwxrwxr-x 4 apatters apatters 4.0K Aug 31 14:43 public
apatters@unimatrix01:~/Local Sites/sacoh/app$ cd public/
apatters@unimatrix01:~/Local Sites/sacoh/app/public$ ll
total 4.0K
drwx------ 2 apatters apatters 4.0K Aug 31 14:43 _wpeprivate
apatters@unimatrix01:~/Local Sites/sacoh/app/public$

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.