Local Community

Can't import site from WPEngine

Issue Summary

Unable to import site to Local from WPEngine. Error “Uh Oh! Unable to import site.” then referencing a problem with wp-cli.phar what looks like doing a search replace to update dom

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Only tried with the one, but it’s the one i need to import

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    yes

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!
Connect WPEngine to Local, import site, configure accordingly

System Details

  • Which version of Local is being used?
    6.4 +5927

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
      Windows 10 pro
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @mikeub, thanks for using Local!

Looking at your log file, I see something similar - it looks like the search replace command fails to run for some reason. Is there any antivirus or other similar system on your machine that could be affecting Local’s permissions to run that command? I wonder if so, if disabling that would allow it to complete.

I understand the priority is getting this one working. While we troubleshoot, can you try pulling another site and seeing if the error is somehow specific to this one?

Thanks,
Austin

Tried again with Norton disabled - that’s the only relevant antivirus etc i can think of running - and same result. Tried pulling down another site - worked fine. only difference was the folder i pulled the second site down to, so tried the original site to the same location and it worked.

Looks like it must be a permissions issue - which is weird, because the path I installed to originally isn’t locked down at all so I’m not sure why the script would fail there. Immediate “crisis” is solved I guess - but I’d still call it an issue because the default folder is not where I want this site (or any of my sites) to live…

That is definitely still odd… I assume you were pulling to a new site, and when creating that site, specifying the custom site path?

What were the two locations you were trying to pull down to, the one that worked and the one that didn’t? That makes me feel like system permissions are off, but that would be strange.

Correct on both counts.

I typically “host” sites in any of a number of folders on my m: drive - ie m:\client\site. Have never had an issue before, and again, no weird unique permissions on them that I’m aware of.

The directory that worked this time around is whatever local tries to default to - ~\local sites\client\site or the like I believe. Which obviously has special roots around the current user, but since the current user is also the system admin and there are no limited rights elsewhere, I’m just surprised the script was unable to run.