[SOLVED] Fatal error: Uncaught Error: Class "League\Flysystem\Adapter\Ftp"

Issue Summary

Hi, I’m using PHPloy for syncing my local code with production.
I tried LOCAL for first time, and when I tried to use it I get error:
Fatal error: Uncaught Error: Class “League\Flysystem\Adapter\Ftp” not found in /Users/{user}/.composer/vendor/banago/phploy/src/Connection.php:89
Normally I would just activate PHP extension, but I can’t find here any options for this, I’m not sure how to add it using comand or smth. I tried run command both in iTerm and project console (using LOCAL connection to project console) And in both cases I face same issue.

System Details

LOCAL: 6.3.0+5756
MAC OS v 12.1 Fresh install, instaleld PHP using brew

LOG: local-logs.zip (2.6 KB)

How I can add FTP extension or fix the issue?

Actually I solved the issue by installing older PHP - 7.4
then running command

composer global update

Which downgrader/updated dependencies for required php.
So basically this is issue php 8.1 related.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.