Hey there,

Thanks for the software, I’m pretty eager to get this working.

Please let me know what information you need from me exactly and I’ll provide it, I am currently having an issue of ERR_CONNECTION_REFUSED for Mac. Do you need my Mac specs?

Sorry for the bump, here is the screenshot of the hosts file.

Hey Andrew,

Can you try using a TLD such as .local?

You might have a local DNS server that’s trying to resolve .dev TLDs.

Hey Clay,

Thanks for the quick response :slight_smile:

I managed to resolve this issue by completely removing the Get Fly Wheel and then reinstalling it.

You may close this thread! Have a great day further.

1 Like

I’ve got this problem. Should I start a new support inquiry? I’ve gone through several of the solutions from here plus online inquiries but I’m not finding a fix.

  1. Completely deleted everything & Reinstalled
  2. Shut down and restart
  3. have tried and fun.local – I don’t think it is a TLD issue
  4. Ping fun.local => returns local value from hosts file
  5. I use homebrew and I’ve updated and upgraded
  6. Disabling Firewall does not improve the problem
  7. No virus app installed at the moment


FWIW, here is the step I followed to completely remove it and then I just did a fresh install which worked for me - How do I uninstall Local on macOS?

I hate to ask this, but have you tried different browsers? It sounds like the DNS/hosts file is getting cached hard in the browser.

Hello, I did test and I’d get a similar error on Firefox.

Lately I started working with Trellis Deployment tool by Roots. I’d had a problem much the same and found that having more than one version of PHP on my Mac might have been part of the problem. Since I’ve started working in php7.1 all other versions were uninstalled. There is a way to have more than one version of php installed, however in my case they were globally installed. Testing Flywheel, it did not solve the problem.

Uninstalled Flywheel with methods linked above. I added a new .dev test site and now I’m getting a Name Collision Error, ERR_ICANN_NAME_COLLISION. Forever onward …

After working through possible solutions, a change that fixed it was to disable an app I use for managing hosts file called ‘Gas Mask.’ It has been very effective, but it starts when the machine starts it is easy to forget.

Before using Gas Mask, I used a Preferences pane add on called Hosts. After opening it, I found it works without a hitch with Flywheel. See this OSX Daily post. You access it via the Preferences panel.

My problem is now SOLVED. Thanks to both of you for contributing.

Another little trick is to use $ wget in your terminal. It offers a number of helpful checks plus you can use it to download things.

$ wget
--2017-05-04 13:23:40--
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: ‘index.html.1’

index.html.1            [ <=>                ]  50.26K  --.-KB/s    in 0s

2017-05-04 13:23:41 (258 MB/s) - ‘index.html.1’ saved [51464]`
1 Like

A post was merged into an existing topic: Err_connection_refused after installing local

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.