Local Community

Special characters not imported correctly

Bug Summary

When importing a website (in my case from a BackupBuddy export), special characters are not imported correctly.
For example: é becomes é and ë becomes ë

Steps to reproduce

  • Drag a zip-file onto Local (in my case a BackupBuddy export)
  • Let it import
  • Open site in browser
  • All Special characters are malformed

Environment Info

Describe your environment.

  • Mac Catalina
  • Nginx, PHP 7.4.1, MySQL 8.0.16
  • Local Version 6.1.8+5621

Not sure if Local can fix this during import but here I found a quick fix:

Adding the following to my wp-config.php fixed it form me for this particular site:

define(‘DB_CHARSET’, ‘latin1’);
define(‘DB_COLLATE’, ‘’);

1 Like

Yeah, Charset and Collation are topics that are pretty specific to the individual DB. There might be additional calculations Local can do to give a best guess as to what settings to use, but in my experience these kinds of DB issues are hard to reason about and generalize.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.