Ut8_general_ci in source DB and Local as well. Mangled characters anyway

Issue Summary

I’ve used a manual export (no plugin involved) to import into Local. Both databases have ut8_general_ci collation. The transported SQL file is UTF-8 encoded and has all the (german Umlauts) fine. No strange characters anywhere in it. But in WP Frontend, Admin-Backend and Adminer shows ® für, whereas it should read ® für. No idea, what could go wrong here.

Screenshot 2023-07-05 at 14-16-37 Datenbank auswählen - Adminer
Screenshot 2023-07-05 at 14-17-02 STRATO phpMyAdmin 4.9.2

System Details

  • Which version of Local is being used?


  • What Operating System (OS) and OS version is being used?

Linux (ubuntu derivate)

best regards

Hi @hartmann_ch

Since the site came from elsewhere what WP/PHP versions was it on? Do those match the ones in Local?

Have you tried doing any search and replacements to fix up the special characters?

You might also want to update to the latest version of Local since we are now up to 7.0.2

thx for your reply and questions. took me a while …

same WP: 6.2.2
tried new import with Local 7.0.2
PHP: 7.4.33 (original site), 7.3.5 in Local

problem persists :frowning:

as the exported SQL file is 100% perfect (and so is the local file ~/app/sql/backup.sql),
but the local database already shows the problem, i see the point of “failure” during the import.
Screenshot 2023-07-08 at 12-49-34 Bearbeiten lvej_posts - Adminer


Hi there @hartmann_ch -

Have you considered trying WP Migrate? I know you mentioned using a manual export but if you’re able to, you might see if that works.

Here is a resource for that:

Let me know if this helps,


thx Sam(?) :wink:

the backup has been created through a tool of one of the biggest german hosters (“Strato”)
months ago (around early 2022), so using a plugin is unfortunately not an option in this case.

I’m actually also not the guy, who’s using plugins for this purpose normally.

Just for the sake of proove, i might will give the plugin a try with the current site , but won’t bet
my money on it.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.