Specify project name with hyphen

I have a git-managed repo which includes a hyphen in the name. The problem is when setting up a project in local, it doesn’t allow me to modify the project name within the local site path.

That’s a real issue because I won’t be able to migrate this project. Local’s project folder name needs to be identical to the git-managed project.

Is there a way to allow modifying the project name? I tried after setting up the project, but Local just added a directory with the old project name.

System Details

  • Which version of Local is being used? Local 5.10.3

  • What Operating System (OS) and OS version is being used?
    MacOS 11.2.3

I’m having a little trouble thinking through what’s going on – Do you have a screenshot to help me visualize?

Is the Git repo a site-level repo that you’re trying to use at the sitename/app/public root, or is something else going on?

Might be related New site strips dashes

1 Like

@ben.turner Yes, the repo is site-level.

@afragen Yes, sort of. The domain url remains intact with the hyphen (IE: test-site.local), but the project directory does not (IE: testsite). And it can’t be modified either during the setup process.


In fact, I think this is the same issue previously described. I would love it to be fixed. In early versions, I don’t remember how far back, it did work.

Thanks for the screenshot, this has shown me a “feature” of Local that wasn’t aware of!

The Site Name in Local is only used in the Local GUI, so would it be possible to name the site test site and let it auto infer the dashes?

I’m curious though, are you not able to manually update the path and domain to whatever custom values you want?

I was able to name a site dashed-site and update the other values accordingly:

1 Like

@ben.turner no I wasn’t able to do that. I could name my domain with a dash, but Local wouldn’t allow me to change the folder name like you have illustrated in your screenshot above. It would automatically name it without a hyphen. I can change the site path location but not the directory folder name. It’s kind of frustrating. I tried on MacOS 11.2.x and 11.3 with Flywheel 5.10.3+5332

I’m not able to replicate what you’re seeing – can you record a screencast of the behavior you’re seeing?

I’m able to click “New Folder” within finder and name the folder whatever I want:

1 Like

OH gotcha!
I see, at 13 sec into your video, you actually have to create a new folder with the hyphened name, so it’s not being derived from the automated name.

I was trying to edit the actual “Local site path” input field instead because that made more sense to me.

This might also have to do with muscle memory. Coming from MAMP Pro, that local site path endpoint, isn’t filled in until you actually chose the project’s directory. In other words, according to your screencast, the “dashedsite” name wouldn’t be auto generated.

1 Like

Nice! I’m glad we were able to figure things out and get a workaround for you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.