SSL stopped working on all Local sites: This site can’t be reached The connection was reset

Issue Summary

Almost all sites (5) stopped working. Randomly one still works. They all give the site can’t be reached message.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

All but one.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

When I create a new site it works. If I try to import a site, it does not. When I imported a database from the live site using WP_CLI, the new site stopped working.

  1. Created a new site, and it worked
  2. Followed these steps and it completely stopped working:
  3. wp db export local.sql
  4. wp db reset --yes
  5. wp db import live_database.sql
  6. wp db search-replace "//" "//liveurl.local"
  7. Followed these steps and it started working again with the original database created by Local:
  8. wp db reset --yes
  9. wp db import local.sql

Adminer works fine. WP_CLI keeps working.


No idea. This came out of nowhere. I had been working on one site yesterday. I started a second site today and it didn’t work. Then I realized the other site wasn’t working either now. Going through the sites, none worked anymore. I restarted the computer, but it had no effect. I tried changing the domain name, nginx to apache and back, the php version. Nothing worked.

I am reporting the problem, but I am going to have to rip out Local as much as I can and reinstall. I have too much to do tonight…

System Details

  • Which version of Local is being used?

Local 5.9.9+5246
I was using 5.9.7 when it started. I had to manually download 5.9.9, but the problem persists.

  • What Operating System (OS) and OS version is being used?

Mac Big Sur 11.2.1

  • Attach the Local Log

Local Router’s logs: Local Router's Logs -
Local’s log: Local's log -

local-lightning.log (522.2 KB)

Ok. I just followed the below steps to import the live database and then convert it to http: instead of https:, and it started working. I have trusted the SSL cert, but it is not working with SSL for me. This was the difference with the one site that works. It was was not https. This appears to be related to SSL, but I have no idea why it started suddenly and what could be causing it.

  1. wp db reset --yes
  2. wp db import live_database.sql
  3. wp db search-replace "//" "//liveurl.local"
  4. wp db search-replace "https://" "http://"

That last step is messy since it will change all urls, but for my site, it is fine.

I will work without SSL for now. I am not a hundred percent on how to fix this, and I am looking forward to ripping all of Local out…

Screen Shot 2021-02-22 at 12.14.21 AM Screen Shot 2021-02-22 at 12.14.31 AM

I also tried deleting the SSL certificates (mac keychain), and then retrusted them. It has no effect.

5.10 did not fix this issue.

I take that back. Between updating to 5.10 and restarting the computer, the issue is fixed. It IS possible that I have not restarted since the issue started… So try restarting…

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.