Stuck on "Starting Local Machine" after updating to 2.1.1

Since i originally posted this topic in June, i have been able to use Local by starting and restarting it 4 or 5 times each time until it is functional. This is not great but it worked (with difficulties)

But now with the new update 2.1.1 even after starting Local 10 times or more, i am still stuck on “starting local machine”

I have to use it so i had to reinstall the previous version 2.1.0

All this is the same either on my iMac and on my Mac Book Air.

Hi @gbettant,

The next time this happens, can you get the local-by-flywheel.log file? You can find it by going to Help » Reveal Local’s log.

I have the same issue as gbettant. Since first installation, I have to start and restart Local a few times before it connects.

Today, I’ve tried on and off for hours and cannot connect. It’s stuck on “Starting Local Machine.” So I upgraded to 2.1.1. and it didn’t make any difference. Local is still stuck on “Starting Local Machine.” Please help. Thanks.

local-by-flywheel.log (125.1 KB)

Hi @JT8888,

There’s a conflict in the /etc/exports file. This will be resolved in Local 2.2.

In the meantime, please try Can't start Flywheel

I followed your instructions but that did not work.

Alternatively, you can disable NFS in Local by adding a JSON file in ~/Library/Application Support/Local by Flywheel named nfs.json containing { disabled: true }

Then, relaunch Local.

Since trying that, I’ve uninstalled Local and re-installed it. Now it’s stuck on “Local Machine.” Sigh. I appreciate your help Clay and know you’re working hard to provide support to everyone. Please advise as to what I can do now. Thank you.

local-by-flywheel.log (382.6 KB)

I just installed Local by Flywheel on a Mac and run into the stalled “Starting Local Machine” problem as well. When is the Local 2.2 version expected? Would love to use it!

Anyone have any luck getting past “Starting Local Machine?” I’ve looked through the forums for help but nothing seems to work.

Clay? Anyone?? Still unable to open… Thank you to anyone in advance for help!

Hi @JT8888,

It looks like you’re still running into the same issue. The nfs.json file may not be saved correctly.

Here’s a different solution for now:

  1. Open Terminal
  2. Enter sudo nano /etc/exports (enter your password when prompted)
  3. Remove every line
  4. Restart Local

That worked!

Thank you, thank you, thank you Clay!

Stuck on Starting Local Machine.

Running Version 2.0.8 (2.0.8). Can’t update Local.

Tried the fixes listed in this thread. Still not working.

Please advise.


local-by-flywheel.log (157.7 KB)

Hi @gbettant,

Thanks for the log!

Please give Local 2.2.0 (pre-release) a try. It changes how Faster Docker Volumes works.

I just installed Local by Flywheel on a Pc and run into the stalled “Starting Local Machine” problem as well. and I’m on a windows 10 local-by-flywheel.log (112.8 KB)

Hi @Eric_Strickland,

Sorry for the trouble! It looks like your VirtualBox disk needs repaired.

Can you please try running the following in CMD.exe?

"%ProgramFiles%\Oracle\VirtualBox\VBoxManage.exe" internalcommands repairhd "%HomePath%\.docker\machine\machines\local-by-flywheel\disk.vmdk"

i did that sir and i got this: No file format specified and autodetect failed - please specify format: VERR_NOT_SUPPORTED

maybe i didn’t do it right?? you think?

i put this: C:\Users\erics>“ProgramFiles\Oracle\VirtualBox\VBoxManage.exe” internalcommands repairhd “HomePath.docker\machine\machines\local-by-flywheel\disk.vmdk”

man I have no idea what I’m doing!!

No idea if this might help somebody else, but I was able to get Local running again on macOS 10.13.1 (after upgrading to 2.1.2 and getting constant stalled “Starting local machine…”, “Restarting…”) by:

  • Downloading 2.2.0 (pre-release) and just replacing the Local by file in Applications
  • Doing the “sudo nano /etc/exports” scrub mentioned by @clay here
  • Opening
  • Right-clicking local-by-flywheel (which was running even though Local was closed) and Close > Power Off
  • Reopening Local