The Site Can't Be Reached

I have installed local and set up a new local site. When I click Admin or Visit site, I get a browser error “The site can’t be reached.”

I checked the php log and got a bunch of these:

[10-Jan-2018 22:39:04 UTC] PHP Notice: Undefined index: SERVER_SOFTWARE in phar:///usr/local/bin/wp/php/WP_CLI/Runner.php(1020) : eval()'d code on line 75

I have restarted the local machine
local-by-flywheel.log (21.6 KB)

Help please! I’m running this on a Mac.

Hi Kristen,

Sorry for the trouble!

Can you please try the following?

  1. Go to Preferences » Advanced
  2. Disable “Faster Docker Volumes” if it’s enabled

Thanks for the response.

I did that and am still unable to connect to the site.

Got it.

Can you provide a screenshot of what you’re seeing in your browser?

clay Lead Local by Flywheel Engineer
January 11
Got it.

Can you provide a screenshot of what you’re seeing in your browser?

Visit Topic or reply to this email to respond.

In Reply To

January 11
Thanks for the response. I did that and am still unable to connect to the site.
Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Any update on this? I really need to work on this site.

Hi @kristenwhitney12

I don’t think that the Undefined index: SERVER_SOFTWARE notice is what is causing the site to not load. Notices don’t typically cause the whole site to fail.

When I look at your log file, it seems like the SSL certficate – the thing that verifies the site to your browser – hasn’t been created.

Can you try creating a new site and see if that site creates the certificate?

If not, then you might try restarting the VM as well as the laptop. Somehow you want to get a certificate created for the site so that the browser can load it.

If you have any other questions, just let me know!

– Ben

I have created a new site and am still unable to access it.

What happens when you click the button to “Trust” the certificate under the SSL tab?

Are you able to open the site after it has been trusted?

I get a notification (below), then nothing.

Anything? I really need this issue resolved.

Hi @kristenwhitney12,

It looks like there’s an error with one of the dependencies in Local. Specifically, the OpenSSL binary that ships with Local.

Are you running anti-virus of any type? Also, have you tried redownloading Local?

I have re-downloaded, deleted and re-added the site, and done everything
else and it still does not work.

I have also attempted to add an additional site with all of the same

Got it. Can you provide the log file again?

Also, are you running anti-virus of any type?

Thank you for your patience!

I’m working on a Mac and am not running any anti-virus.

Attached is the log.

local-by-flywheel.log (48.2 KB)

I have uninstalled and reinstalled Local and it is still not working.


Sorry for the delay getting back to you on this. It looks like the default configuration file for OpenSSL is missing.

Can you open Terminal and run the following command?

cp /System/Library/OpenSSL/openssl.cnf /usr/local/ssl/openssl.cnf

As long as there aren’t any errors after running that command, try re-opening Local and creating a new site.

Hi, I think I have the same problem. I’ve newly installed local and set up a new local site, on a Mac, but when I try to view site I get the same ERR_CONNECTION_REFUSED page in Chrome. (Safari won’t finish loading and Firefox says “Firefox can’t establish a connection to the server”.)

In my Local log, this error keeps coming up:
Error: CERTIFICATE not found from openssl output:

WARNING: can’t open config file: /usr/local/ssl/openssl.cnf

And when I run in Terminal the command you’ve provided above, I get the following return:
cp: /usr/local/ssl/openssl.cnf: No such file or directory

Any ideas how to fix this?
Faster Docker Volumes is disabled, the Environment is Preferred, I’ve clicked “Trust” in SSL and entered admin password on prompt, no anti-virus software is running, I’ve restarted Local Machine, and I’ve completely uninstalled Local and VirtualBox and re-installed them following your steps provided here.
Many thanks for any help, I’m excited to get Local working!

I have the same issue. On sites I was previously working on and adding new sites. The database connection does not work. I get this message and similar for all sites:

This page isn’t working
cornish-seascapes.local didn’t send any data.

I did notice in the Wordpress installation that there was no wp-config file, so I used the sample file to enter the database details. i still can’t access.

I didn’t really know what i was doing with Terminal but I also got the message: No such file or directory

Can you help?