The update messed all up :(

Issue Summary

I updated flywheel local, and it didn’t finish updating. It didn’t go well, I had to end it manually, and after that, all my sites where gone from flywheel (folders are still on the file system). And starting again, creating new sites, they don’t work well, no SSL and local router problems even when I followed the steps.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All the sites have the same “heads-up! Local’s router is having trouble starting.” If I change the router mode, then I have no SSL and I need it to work for some functionalities to work properly.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Only with the Router mode: localhost.


I don’t really know what happened during the update. It closed suddenly with no message. I found that the new exe was downloaded, so I executed it.

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    Windows 10 x64

  • Attach the Local Log.
    local-lightning.log (109.9 KB)
    NGINX log error.log (8.7 KB)

Maybe I should delete all and start again? It is quite bothersome, as I had already started creating 2 sites again… :frowning:

I also need this working as soon as possible to start other new projects…

Thanks for all the help in advance.


It’s possible that there was an issue during the update process that’s related to a bug we just fixed. Can you try downloading and installing the latest version of Local (5.10.1)

You might also try a restart of the computer to ensure that any lingering Local processes have been stopped.

Ok, I deleted all the sqls that I already had on my computer. Too much time without cleaning up. And I installed it again. Ok, it worked, the 2 last sites I created after the update were still there, and I could run them with the domain.

Now I am stuck again, it stopped working again, and I can’t run my sites… :confused: or they work shortly and later I have an Uh-oh message (see later).

I just updated today, I thought maybe it would be fixed… But it is here again, and sometimes work sometimes doesn’t and I really needed it to work fine.

[Window Title]

[Main Instruction]
Uh-oh! Unable to change site domain to host.


Error: Command failed: "C:\Users\rach1\AppData\Roaming\Local\lightning-services\php-7.4.1+14\bin\win64\php.exe" "G:\local-flywheel\resources\extraResources\bin\wp-cli\wp-cli.phar" --path="C:\Users\rach1\Local Sites\web-diy-2\app\public" --require="G:\local-flywheel\resources\extraResources\bin\wp-cli\local-wpcli-error-reporting.php" --skip-plugins --skip-themes --url=localhost:10011 "search-replace" --all-tables-with-prefix "http://localhost:10011" "http://web-diy-2.local"
Error: Required file 'local-wpcli-error-reporting.php' doesn't exist (from runtime argument).

    at ChildProcess.exithandler (child_process.js:304:12)
    at ChildProcess.emit (events.js:223:5)
    at ChildProcess.EventEmitter.emit (domain.js:475:20)
    at maybeClose (internal/child_process.js:1021:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)


error.log (41.0 KB)
local-lightning.log (206.4 KB)

There’s definitely some odd things happening here.

That file that is mentioned – local-wpcli-error-reporting.php comes bundled with Local, and should exist.

Additionally, when looking at the Local log, I see an error that looks like:

{"thread":"main","class":"SiteProcessManagerService","stack":"Error: EBUSY: resource busy or locked, copyfile 'C:\\Users\\rach1\\Local Sites\\web-diy-2\\conf\\apache\\mime.types' -> '%%userDataPath%%\\run\\DzwVSv066\\conf\\apache\\mime.types'","level":"error","message":"Unable to start site.","timestamp":"2021-03-30T17:04:20.089Z"}

This sort of makes me think that something is getting in the way of Local doing what it needs to do.

Do you have any antivirus software running and watching for changes to things that Local might be doing?

Thanks for taking a look into it. Yes, I use Avast. But it didn’t gave me any problems before, and I have been using Avast + Local for some years.

I tried disabling both the antivirus and the windows firewall just in case. A new site that I just tried creating doesn’t work (can’t access this website on wp-admin and unstyled content on fron-end) maybe some files couldn’t be copied. And the old ones give me errors like " Gateway Timeout

The gateway did not receive a timely response from the upstream server or application."


Is there something I can do to fix this? Reinstall again?

more logs…
local-lightning.log (249.5 KB)

Thanks and best regards,


I think trying to re-import the site after Avast has been disabled is a good idea.

You can use a backup of the site, or try using the files for the site by following the steps outlined in the “Restoring From Only Local Site files” section of this help doc:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.