Uh-oh! could not update hostsfile

Hi All
new to Local have just downloaded and installed but getting message
Uh-oh! Could not update hosts file
Please ensure that the hosts’ file is not set to read-only and/or locked by anti-virus
followed all the info and anti-virus and host file
but still nothing

any help appreciated

Well! I was experiencing the same issue, but I disabled my antivirus and it works fine.
Try to disable your windows firewall and retry.

1 Like

I’m having this same issue. I have no antivirus and the read on;ly flag isn’t set on the host file. This looks like a bug to me. A notification pops up to say Local is requesting permission to update the host file but no request appears. The local-lightening.log file has an entry that states :slight_smile:{“thread”:“main”,“class”:“HostsFileService”,“error”:{“message”:“User did not grant permission.”,“stack”:“Error: User did not grant permission.\n at C:\Program Files (x86)\Local\resources\app.asar\node_modules\sudo-prompt\index.js:534:29\n at ChildProcess.exithandler (child_process.js:315:5)\n at ChildProcess.emit (events.js:203:13)\n at ChildProcess.EventEmitter.emit (domain.js:476:20)\n at maybeClose (internal/child_process.js:1021:16)\n at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)”},“level”:“error”,“message”:“Could not update hosts.”,“timestamp”:“2020-01-24T12:10:23.776Z”}

However the user can not grant permission as a pop up does not request it. Only a notification pos up which is an information only pop up not a request. So must be a bug ???

Trouble is without using domains when the site logs in to other plug ins where we track what sites we have regestered for licensing it doesn’t show the domain just local host.

I’m having the same issue and need some help as well. Here is my log file, thanks. local-lightning.log (38.6 KB)

I am also having the same issue. I just downloaded Local, installed my first Wordpress website, and promptly had this issue trying to get it to run. I have a warning: “Missing hosts entry. This site may be inaccessible.” I have followed instructions here, but it still doesn’t work. The only antivirus software I have is Windows Firewall, and everything seems fine there, so I’m not sure what else to do. I’m uploading my log file, so if I could get some help with this issue, it would be much appreciatedlocal-lightning.log|attachment (59.2 KB)

Closing the program and running it as administrator solved the issue for me.

same issue here. Was looking forward to this. Have uninstalled anti-virus, vpn’s followed every instruction in every post and still the same issue.

Having the same issue. But @roy’s method doesn’t work for me, because I have my Windows users setup so that I am a non-admin user, which is better for security if I ever get hacked. This means if I switch to open Local as an admin, then it’s an entirely separate app and all links in the Local open as admin which means in the admin user profile. Not what I want. It seems the Local app wasn’t really developed for this use case, where the main Windows user is NOT an admin and has to type in the admin password whenever anything changes or is installed etc. Wondering if this could be accounted for in a future update?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.