Uh-oh! Unable to import site. Error: This does not seem to be a WordPress Installation

Issue Summary

Pulling a remote site from WPEngine results in an error

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    This happens in all my remote servers (dev, staging, production) on my Windows 10 PC.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

  1. Connect to WPEngine
  2. Try to pull a site
  3. Before it can finish, it throws the following error


System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • Edition Windows 10 Pro
      Version 20H2
      Installed on ‎9/‎15/‎2020
      OS build 19042.985
      Experience Windows Feature Experience Pack 120.2212.2020.0

Processor - Intel(R) Core™ i7-7700K CPU @ 4.20GHz 4.20 GHz
RAM - 16.0 GB

  • Attach the Local Log. See this Community Forum post for instructions on how to do so:
    -local-lightning.log (87.5 KB)
    Log note: I installed a new, plain WordPress site for filling out this post, I see the error above it on line 406

A few lines before that error are some interesting messages:

{"thread":"main","class":"DevKitService","message":"client_loop: send disconnect: Connection reset by peer\r\nrsync: connection unexpectedly closed (633506194 bytes received so far) [receiver]\nrsync error: error in rsync protocol data stream (code 12) at io.c(226) [receiver=3.1.2]\n","level":"warn","timestamp":"2021-06-07T15:21:46.761Z"}
{"thread":"main","class":"DevKitService","message":"rsync: connection unexpectedly closed (830486 bytes received so far) [generator]\nrsync error: error in rsync protocol data stream (code 12) at io.c(226) [generator=3.1.2]\n","level":"warn","timestamp":"2021-06-07T15:21:46.761Z"}

Note this part, which seems to indicate that the network connection was interrupted while Local was downloading the site files:

rsync: connection unexpectedly closed

If the plain WordPress site is working for you, it might be that the site that was pulled from WPE wasn’t fully downloaded. I would try re-pulling the site using Connect and if you still have issues, you might try downloading a backup of the site and then import it into Local by dragging and dropping the zip onto Local.

Hi @ben.turner Thanks for your response. I’ll give those 2 options a try.

1 Like

@ben.turner I tried re-pulling the site and I ran into the same error message.

Downloading from WPEngine and Dragging the ZIP into Local resulted favorability. Sort of. I noticed not all features existed as they do on the remote staging server. So decided to connect the local site to WPEngine and do a pull… It didn’t give me any error messages, but when it was done, this is what happens when I open the site

Here’s the new log file:local-lightning.log (844.6 KB)

I’ve seen these errors before when creating a new local WordPress site, and then pulling from WPEngine.

The original developer was on PC (and clearly it worked for him). It also worked on my Macbook Pro - None of the errors I’m having on my PC version. Do I need to set permissions with Windows?

I contacted WPEngine Support and got my unique situation sorted out. Here’s what Spencer said:

I’d mention that the debug logging should be made a public feature, something that can be toggled on/off within Local instead of having to add defines to wp-config.php manually but also include that adding the defines I gave you will remove the warnings that aren’t critical errors that prevent the site from working properly.

The fix to get around those messages were to add this in your wp-config.php file, add it right under the table_prefix

ini_set('error_reporting', E_ALL );
define('WP_DEBUG', false);
define('WP_DEBUG_DISPLAY', false);

So hopefully this helps someone in the future who is seeing strange errors keeping them from getting their work done. All is well that ends well.

Thanks @ben.turner for getting me part of the way there.

I’m glad you got it sorted! I was in meetings all day, but now I’m here!

That’s a great tip from WPE support. The main thing I would add is that since Local is a dev environment, it has a number of debugging tools and settings enabled out of the box – for example Xdebug enabled and more verbose error reporting.

Those settings you put in place basically turn all of those things off, but if you’re curious to know a bit more about this topic, this help doc goes in more detail:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.