Uh-oh! Unable to provision site - on Mac m2

Issue Summary

Not able to create a new site.

Troubleshooting Questions

  • Happens on all the sites

  • NOT able to create a new, plain WordPress site in Local and access it in a Browser?


Getting this error when trying to create a new site -

Error: Error: spawn Unknown system error -86

at ChildProcess.spawn (internal/child_process.js:403:11)

at spawn (child_process.js:562:9)

at execFile (child_process.js:246:17)

at t. (electron/js2c/asar_bundle.js:5:2242)

at /Applications/Local.app/Contents/Resources/app.asar/main/_helpers/execFilePromise.js:1:582

at new Promise ()

at Object. (/Applications/Local.app/Contents/Resources/app.asar/main/_helpers/execFilePromise.js:1:534)

at Generator.next ()

at /Applications/Local.app/Contents/Resources/app.asar/main/_helpers/execFilePromise.js:1:330

at new Promise ()

System Details

  • Which version of Local is being used? - 6.5.2

  • What Operating System (OS) and OS version is being used?

    • macOS Monterey 12.5

local-details.json (709 Bytes)
local-lightning.log (15.7 KB)

Hi @vishaal

In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

I have exactly the same problem on two different Computers. Both run MacOS Ventura 13.1 (22C65). One is a M1 MacBook, the other is a M2 MacBook Air.

I tried this approach to shutdown all other apps, but it did not work. I tried Local 6.6.0 and the latest 6.6.1.

What can I do now? Thank you for any hint and help. That is greatly appreciated.


I found this in my log-file:

{"thread":"main","class":"Updater","level":"error","message":"Current platform not found in Releases Manifest. SentryId: 94e809513fa24a0984a32c669ceb7fe2","timestamp":"2023-02-14T20:32:26.564Z"}

{"thread":"main","class":"SiteProvisionerService","stack":"Error: spawn Unknown system error -86\n    at ChildProcess.spawn (node:internal/child_process:413:11)\n    at spawn (node:child_process:709:9)\n    at execFile (node:child_process:336:17)\n    at t.<computed> (node:electron/js2c/asar_bundle:5:2206)\n    at %%appPath%%/main/_helpers/execFilePromise.js:1:583\n    at new Promise (<anonymous>)\n    at Object.<anonymous> (%%appPath%%/main/_helpers/execFilePromise.js:1:534)\n    at Generator.next (<anonymous>)\n    at %%appPath%%/main/_helpers/execFilePromise.js:1:330\n    at new Promise (<anonymous>)","level":"error","message":"Unable to provision site.","timestamp":"2023-02-14T20:34:21.614Z"}
{"thread":"main","reason":{"errno":-86,"code":"Unknown system error -86","syscall":"spawn"},"p":{},"eventId":"66770898e8344453b183ce2fae7a90f6","level":"warn","message":"Unhandled Rejection.","timestamp":"2023-02-14T20:34:23.966Z"}

I’ve been facing this issue as well in a newly formatted Mac with M1. By taking a look into other applications errors (not related to Local), it seemed that this is a somewhat common error that can be triggered when you’re running an “wrong” version of node. I’m not sure how much this is related to Local, but for me, changing the version of node (and installing Rosetta 2) worked.

As I mentioned, I’m not sure if that’s the case for Local, but what worked for me was this:

  1. Installed NVM (in my case using homebrew)
  2. Using NVM, I installed version 12 (nvm install 12) and set it as default (nvm alias default 12)
  3. I had to install Rosetta 2 to be able to run node 12 (using: softwareupdate --install-rosetta)
  4. Then I ran Local and created a new site without any issues

I’ve tried installing node 14 (and also node 16 in another attempt), but only when downgraded to node 12 I was able to create the site using Local without issues.

I’m not sure if that’s a helpful tip, but it’s what worked for me (even tho I’m using the Local for Apple Silicon), an alternative would be to just install rosetta and see if that works for you (as I haven’t tested this).

PS: Later I was able to switch back to node 19 and create new sites without any issues (that’s why I also recommend testing just installing Rosetta 2 first)

I hope this can be helpful to someone else (and maybe to the devs as well). :slight_smile:


Howdy y’all!

@rodrigomantoan is correct in that Rosetta is necessary for the time being when using Apple Silicon. Our Local Dev team has this on their roadmap and we will definitely update the forums and our releases page with notes once this is resolved.

1 Like

I have run into this problem, both when creating a blank site and importing an existing one. Seems like the Apple Silicon version of Local is not really usable, unless we jump through some hoops and downgrade Node that could have knock-on effects with other projects we have running… Any update on the roadmap to get this resolved and working for Apple Silicon with a modern version of Node JS? (we are running 18.16.0)
Thanks very much

Okay, so installing Rosetta 2 was the solution. No messing with Node version. Seems a bit strange to have an Apple Silicon specific version, but that you have to install Rosetta :slight_smile:

Be good to get exposure on when this will run without Rosetta.


Just to let you know that we have been commenting and tracking this across some other posts here in the forums. While we don’t have an ETA to provide it is on the roadmap for the team to address.

Thanks @Nick-B

Look forward to an update. Thanks to you and the team for Local btw - its a great tool that makes life WAY simpler when dealing with WP.

1 Like

Glad to hear it @nebrekab! Also once we have that update we’ll spread the word here in the forums but on our releases page you can also see a breakdown of what features and bug fixes are included each time as well. Releases - Local

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.