Uh-oh! Unable to start site. mysqladmin: connect to server failed

Hi all,

I’m running Local on Linux Mint 21.2. I recently run into an issue of not being able to start any site or create a new one. I’m not a specialist with Linux but I think (hope) that I found the reason and would like to share this if anyone experience the same.

The error happened when I was connected to VPN. I’m using NordVPN (which I like very much). And I was able to start my sites as soon as I disconnected VPN.

I hope this is of any help for others.

Below is the error message as an image.


1 Like

Did you resolve you pb ? cause I have quite the same error message…

The same thing happens with me.
No VPN in use.
The problem does not occur with most websites, only with very few, it seems to me that the websites were started with version 8.0.
Environment: Windows 11, Local 8.0.1

With these steps I reactivated my project:

  • clone site (to a new folder) of the non-functioning instance: this then worked fine under a new name.
  • deleted the instance that did not work
  • exported working instance
  • created a new instance in the folder where the non-functioning instance was stored before, used the data from the export for the installation
  • Then I have the old state again

same issue as you but I’m good with Linux is there any solution for that?

Same problem here. So, how to fix this error?

Hi @Sidra @Abba

As @fishmi stated, a good way to usually fix is this is by doing a reimport.

You can use steps like these also:

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Restart Local/your machine
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.