Unable to connect to my site

I recently updated my local to version 6.3.1+5826, which I believe is the latest version and from this point on I have been unable to open my website

One or two sentence summary of the issue.

When clicking the button “open site” I receive a message "Safari can’t open the page because Safari can’t connect to the server

  • Does this happen for all sites in Local, or just one in particular?

I have only been building the one site currently. Though I have been working on this site over 12 months and have completed updates before without any issue

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Yes Ive been able to create fresh new site on local. The only thing I can see in the new site is running a newer version of Wordpress and different version of PHP

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    MacOS High Sierra Version 10.13.6

  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

1 Like

Do you see the same issue in Chrome? Can you open the database using Adminer?

I’m on a Linux distro (elementaryOS) and am having errors establishing a database connection

Warning: mysqli_real_connect(): Property access is not allowed yet in {dir}/app/public/wp-includes/wp-db.php on line 1753

Connection refused

Error establishing a database connection
This either means that the username and password information in your wp-config.php file is incorrect or we can’t contact the database server at localhost. This could mean your host’s database server is down.

I had the same issue in Chrome.
Though my issue has fixed it’s self when I created a new site as a test to see if it would work. It did and now my other site works too!!!

My issue stemmed from my laptop not shutting down properly (battery died on me). After a proper shut down + restart all worked again.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.