Unable to Create New Sites

After several weeks of successfully using Local I am now unable to create new sites. Local gets stuck on “Starting Up Site Services” (see attached screenshot). This happens when both importing a site and creating a fresh site within Local.

Previously installed sites continue to run fine.

The problem started after updating to v5.6.1+4184.
Running Mac OS 10.13.6.
Log File: local-lightning.log (360.3 KB)

Please can someone help troubleshoot the problem?

Hi @ElwoodP,

Sorry about this!

I appreciate the screenshot and log file!

The main thing standing out to me in the log file are issues with nginx.

"thread":"main","class":"Process","process":"nginx","level":"warn","message":"nginx: [alert] could not open error log file: open() \"%%site.runData%%/nginx/logs/error.log\" failed (2: No such file or directory)","timestamp":"2020-06-25T15:46:39.811Z"}
{"thread":"main","class":"Process","process":"nginx","level":"warn","message":"2020/06/25 16:46:39 [emerg] 1340#0: open() \"%%site.runData%%/conf/nginx/nginx.conf\" failed (2: No such file or directory)","timestamp":"2020-06-25T15:46:39.812Z"}

If you try creating a site using the Custom environment and Apache as the web server, is it created? If not, you could also try switching up the PHP and MySQL versions.

Tx @clay. Actually I had previously tried Apache and same thing happened. I’ve just tried again with a custom setup of: PHP5, Apache and SQL5. Exactly the same thing happens. :confused:
New log file attached after latest install attempt as described: local-lightning.log (416.2 KB)

It seems by the way that “Starting up Site Services” does eventually disappear. But the site does not work. There is a constant loading gif after “Wordpress Version” (see screenshot).

On further investigation there is very little that has been created in the new site directory. No database, no WP files… Attached is a zip of what was created.test4.zip (19.2 KB)

Having the same issues. Cannot create a new site. Support, please respond - I am unable to work!

OK I completely uninstalled and reinstalled. Still same issue. I then uninstalled and reinstalled an old version of Local – 5.5.2 (the last version I think was working for me). I can now create sites again. So something in the latest versions is breaking for me.

I wonder if Local is no longer compatible with OSX High Sierra? There seems to be a few other posts on the forums recently with similar issue, are they also High Sierra I wonder?

I’ve now updated to Mojave and the latest version of local now works. Maybe something else fixed it during the OS update but I think there’s a change High Sierra is a problem with latest Local if anyone is interested.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.