Unable to Import Sites locally

I’m not sure what is going on but I cannot import any sites locally from zips anymore.

Here is the error I get: image

Local Version: 5.0.7+1117
OS: macOS Mojave 10.14.6
The only option downloading from the homepage was the Beta version - I tried re-installing and it gave me the Beta version again.

I’m getting the same thing man this is frustrating for a newbie with no clue. Somone please help!!!

Error: Command failed: /Applications/Local.app/Contents/Resources/extraResources/site-binaries/mysql-8.0.15/bin/mysql --default-character-set=utf8 -A --skip-column-names -e SET names ‘utf8’; use local; source /Users/tyronnechisholm/Local Sites/elderberrydev/app/sql/local-schema-create.sql;

ERROR 1007 (HY000) at line 1 in file: ‘/Users/tyronnechisholm/Local Sites/elderberrydev/app/sql/local-schema-create.sql’: Can’t create database ‘local’; database exists

I’ve used local for 3 years and never had issues like this. Here is a link to the Non-Beta version which should solve all problems. I haven’t tried it yet but I have seen this issue pop-up a lot recently with no solution. So I’ll put this here to help someone else:

Unfortunate, but the older version works, whereas the Lightning version only works for new sites and does not work for importing.

I see you are using an older version of local. So what is the difference and why should I go to the older version. Perhaps thats why you have’t had the problem so being new I’m not sure what to do but have to get this fixed if not have to redo all sites that I created! Not good!

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.