Unable to start site on Windows (MailpitService.start error)

What issue or error are you experiencing?

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details: Windows 10

  • Local Version: 8.3.1+6650
    Local Error

  • Operating System (OS) and OS version:

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.
Local Error
Local Error

Hi, @shady00071

Are you using 32-bit Windows? (How to find out.)

The Mailpit service used in the new Local 8.3.1 only supports 64-bit Windows. You can either downgrade Local or upgrade to Windows 64-bit:

Hi [nickc]
Yes My windows 10 is 32-bit version, so I have to use other version of local. I will try local 8.0.2 May be It can solve my problem.
Thank you for your help.

I already changed local version, but no way. See Pics Below

@shady00071 8.2.1 should work for you. You should not need to downgrade as far as 8.0.2 unless there’s another reason for this.

If you downgraded from 8.3.1 to a lower version and want to run the current site (rather than create a new one) you’ll also need to follow the steps I linked previously under “If you decide to downgrade from Local 8.3.1 to an older version of Local…”.

I changed local version to 8.0.2 But no way.
I tried to find ‘mailpit’ with ‘mailhog’ But I can’t find it.

The path to the ‘sites’ file is:

This PC → Local Disk (C:) → Users → shady → AppData → Roaming → Local → sites

(You’re looking in the ‘shady → Local Sites’ folder instead.)

To see the “AppData” folder, you may need to “show hidden items” in File Explorer.

Once you can see the ‘sites’ file, open it in a text editor and make the changes mentioned before. Here are the steps again for convenience:

  1. Open the Windows File Explorer.
  2. Make sure you have enabled “show hidden items”.
  3. Browse to This PC → [your hard drive] → Users → [your username] → AppData → Roaming → Local.
  4. Make a backup of the sites.json file (it might just appear as ‘sites’) by duplicating it as sites-backup.json or similar.
  5. Open sites.json in a text editor.
  6. Find and replace ‘mailpit’ with ‘mailhog’.
  7. Find and replace ‘1.12.1’ with ‘1.0.0’.
  8. Save the file and restart Local.

You only need to do this if you want to use your current “Facts & Informations” site with Mailhog after downgrading from Local 8.3.1, though. You can alternatively delete that site and create a new one. Local/Mailhog will work as before without needing to edit your sites.json file.

I made all changes, but the site not open.

Thanks for the screenshot, @shady00071.

I still see a ‘mailpit’ in your code:

"mailpit": { "name": "mailhog"

You’ll need to change that to mailhog too:

"mailhog": { "name": "mailhog"

Then save the file and restart Local.

Thank you very much for your patience with me.
I actually changed the ‘mailpit’, but added the wrong image.
This is the correct picture

The error message no longer appears, and the website also does not appear.
There is definitely an error that prevents the site from appearing. Can you help solve that error so that the site appears again?
Please accept my regards, and my apologies for being preoccupied with my problem.

Thanks for the updated screenshot, @shady00071.

  1. Did you restart Local?
  2. What error or issue do you see when you start the site now?
  3. Can you please also share your logs after restarting and attempting to start the site?

A new development has occurred
When I opened the site now, the page shown in the following image appeared:

Have you tried rebooting your PC since making these changes?

Please share any errors and your logs if this does not work.

After restart Local
pic 1

pic 2

pic 3

The Bad Gatway not appear

I think there are a problem in the site folder.
If you want I can send pics of the site folder.

Does the same thing happen if you create a new, blank site? Are you unable to access that as well?

I created a new website, and it opened without problems, as you can see in the following images

Since the new website opened without any issues could you try cloning or reimporting the site you’re getting errors on?

The steps would look like this:

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Restart Local/your machine
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files

I think the problem is the Admin name. There are difference between the old site and the new one
Pic of the old site (check admin name) it is wrong

Pic of the new site (check admin name)