Missing Mailpit

What issue or error are you experiencing?

HI, I created a small wp site. I quit out of local. The next time I started local I had the error message across the top " Missing Mailpit v1.12. Dont worry well reinstallit next time you start your site." I cannot open the wp site. I get an oh oh error screen shot attached. I have uninstalled local, shut down pc and tried again with fresh installation. I created a simple one page wp site and encountered the same error. I switched off antivirus and still the same problem. Any advice on what to do to solve the problem. Thanks
Local error 3 2024-03-11 154750


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:

  • Operating System (OS) and OS version:


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi, @LizW.

Are you running the latest version of Local (8.3.1)? Releases - Local

If you’re on the latest, please could you share your Local logs?

Hi Nickc, yes I have the latest version. I`m using windows 11.
local-logs1.zip (42.2 KB)

Thank you for the logs, @LizW!

It looks like Local can’t start Mailpit (the service that captures WordPress email for you) because a file Local needs is missing:

file does not exist: %%userDataPath%%\\lightning-services\\mailpit-1.12.1+0\\lib\\main.js"

Local normally copies these files for you when it first starts. You mention that you’re using antivirus software, but that you’ve disabled it. It’s worth checking:

  • That you restarted Local after disabling antivirus software. (Local only writes the above file when it first launches.)
  • That there’s no other security software running that might prevent Local from writing files. For example, here’s how to configure software like Kapersky Total Security to allow Local to run unrestricted. Changes you make will require a restart of Local.

If that doesn’t help, you can try forcing Local to recreate the Mailpit service files like this:

  1. Stop any running sites.
  2. Quit Local.
  3. Open the Windows File Explorer.
  4. Browse to This PC → [your hard drive] → Users → [your username] → AppData → Roaming → Local → lightning-services.
  5. Delete the folder named ‘mailpit-1.12.1+0’.
  6. Make sure antivirus or security software is either disabled or allowing Local to run unrestricted.
  7. Start Local.

Local should recreate the folder named ‘mailpit-1.12.1+0’ at This PC → [your hard drive] → Users → [your username] → AppData → Roaming → Local → lightning-services.

You should then be able to start your site.

If you don’t see that mailpit-1.12.1+0 folder after starting Local, it can mean something prevented Local from writing to the directory. It would be worth checking if you have anything else installed that could do this.

Thank you Nickc - you`re a hero! that worked perfectly :smiley:
Regards

1 Like

Great to hear — thanks for letting us know.