Update cause auto-login to loop back to login screen

What issue or error are you experiencing?

I have just updated my version of LocalWP to the latest version.
After I restart the application, and start one of my site, I click on the WP Admin button.
The login screen displays, I add in my user details and click login and it goes back to the login screen.
I have the “One-Click Admin” turned on. But even turning git off results in the same response


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

trying to login


System Details

  • Local Version:

Version 8.3.2+6660

  • Operating System (OS) and OS version:

Windows 11

Edition Windows 11 Home
Version 23H2
Installed on ‎10/‎21/‎2023
OS build 22631.3447
Serial number 032805314957
Experience Windows Feature Experience Pack 1000.22688.1000.0

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-logs.zip (39.9 KB)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Sorry that you’re seeing a login loop, @erbuc.

I can’t reproduce this in Local 8.3.2 (or the newly-released 9.0.1: Releases - Local).

Some things to try:

  1. Try logging in with another browser with one-click admin disabled. If you can log in there, go back to your default browser, clear your browser cookies, restart your browser and Local, and try again.

  2. If this affects one site (rather than new ones as well), try temporarily renaming your plugins folder from wp-content/plugins to _plugins on the affected site. A plugin could be causing login issues. (From your logs it looks like WordPress updated recently as well as Local, so a plugin may be causing login issues.)

  3. Open the site shell and type “wp option get siteurl”. It should show a website address with either http:// or https://. With one-click admin disabled, check that you are logging in to the wp-admin screen at the exact same URL (e.g. if you see https://mysite.local, be sure to visit https://mysite.local/wp-admin/ and not the http version.)

  4. Open your site’s wp-config.php file in a text editor. Check that the final line does not end in define('NONCE_SALT'. If it does, apply the fix suggested in this post: Unable to login, changing wp-config.php workaround

Thank you Nick,

It was item 4 on your list of things to try.
All fixed up now.

Thanks again for the help,
Eric

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.