Update - install does not complete on Mac

I have version 2 installed. When I open it it tells me it wants to install the update. I go through the steps. It gets to the point where it says, update downloaded, quit Local to install the updates, it will restart when complete. It never restarts. I give it some time and restart it manually, but its not updated.

Hi Patty,

Sorry about that! This is an issue with Electron’s auto-updater but it’s an easy fix.

Please see Error While Updating

This still doesn’t work for me if path is /Applications/LbF. Updating only works if path ~/Applications/Lbf

It looks like the quarantine removal script that was added in 2.0.2 isn’t helping because the application is still open.

Here’s some discussion regarding the issue with Squirrel: https://github.com/Squirrel/Squirrel.Mac/issues/182

It looks like that referenced issue was when the app was in ~/Downloads. Updating does work for me when the app is in the User domain, ~/Applications. It fails in the system domain /Applications as there isn’t a privilege request during the update so the system /Applications folder may be appropriately accessed.

None of these solutions worked. Ran the script. Moved the app to ~/Applications and ran the script. Still no dice. Guess I’ll just do it manually :.


When you run the script are you getting errors about it being in a read-only volume?

I dont get any errors when I run the script.

Any answer to this? I experience the same thing as @pattyok. No error message, no relaunch.


Can you screenshot Terminal after running that command?

here is the screen shot. Not much feedback here.!