Update Themes and Plugins errors

Issue Summary

For a few days now, I have suddenly been unable to update themes and plugins from the WordPress dashboard.

Troubleshooting Questions

  • This problem occurs for every website I use in LocalWP
  • I noticed that if i delete the plugin or theme manually from windows explorer, and then install it from the repository the problem doesn’t occur.
    If I copy a plugin from another site that I have on local wp, then the problem occurs. As if there were no permissions on that directory.

Is there a way to prevent this from happening by copying directories between various local sites?

The problem does not depend on the WordPress version, as I have tried with each version and the scenario is always the same. When I copy a plugin or theme from another local site and try to update later, the update fails. An empty directory is kept, which effectively deactivates the plugin and the updated theme.
Apart from this update problem, which then failing leaves me the directory present, but empty and deactivates the updated plugins because there are no more files in the directory, it works correctly.

Is there a way to fix permissions on the fly on Windows?
I also tried with the command launched by cmd with administrator permissions:
icacls “E:\local-dev\wpdev” /reset /t /c /l
Unfortunately, the problem persists.


Here is the video of what happens:

System Details

  • I’m using latest LocalWP version.
  • Windows 11 OS

Nothing relevant in the LocalWP logs.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.