Update WordPress not working

Been searching the help and support, but cannot figure out how to update WordPress from 5.2.4 to 5.3.
Doesn’t work neither inside the WordPress panel nor inside the Local Flywheel interface.
I even reinstalled the whole thing.
What am I missing?


1 Like

Hey @Musepux, thanks for reaching out and welcome to the Local Community!

What sort of errors are you getting when you try to to update (from either place - Local site dashboard or WP Admin)?

Can you please provide your local-lightning.log file (older versions would be local-by-flywheel.log)?

See this Community Forum post for instructions on how to do so > How do I retrieve Local’s Log?

Hi mattwhosthat, thanks for posting.
I have tried it both ways, even added the auto-update line to one wp-config.
Please find the log attached.

local-lightning.log (294.2 KB) local-lightning.log (294.2 KB)

Thanks for sending that over. What I see is this error:

{"thread":"main","class":"WordPressInstaller","message":"Could not download WordPress.","level":"error","timestamp":"2019-12-02T17:12:22.900Z"}
{"thread":"main","class":"WordPressInstaller","code":"ESOCKETTIMEDOUT","connect":false,"level":"error","stack":"Error: ESOCKETTIMEDOUT\n    at ClientRequest.<anonymous> (C:\\Program Files (x86)\\Local\\resources\\app.asar\\node_modules\\request\\request.js:816:19)\n    at Object.onceWrapper (events.js:282:20)\n    at ClientRequest.emit (events.js:194:13)\n    at ClientRequest.EventEmitter.emit (domain.js:469:20)\n    at TLSSocket.emitRequestTimeout (_http_client.js:673:40)\n    at Object.onceWrapper (events.js:282:20)\n    at TLSSocket.emit (events.js:194:13)\n    at TLSSocket.EventEmitter.emit (domain.js:469:20)\n    at TLSSocket.Socket._onTimeout (net.js:429:8)\n    at listOnTimeout (internal/timers.js:535:17)","message":"ESOCKETTIMEDOUT","timestamp":"2019-12-02T17:12:22.900Z"}
{"thread":"main","class":"WordPressInstaller","level":"error","message":"Error checking for latest version of WordPress","timestamp":"2019-12-02T17:12:22.901Z"}

Basically, it appears that the site is unable to connect to WordPress to download the needed files. Have you tried disabling any firewall services you may be running to see if that is the culprit?

As a workaround, you should be able to download the WordPress files from here - https://wordpress.org/latest.zip - and put them in place directly in your site directory.

Thanks, but even with the firewall disabled nothing gets updated. However, WordPress plugins get installed and Divi gets it’s updates.
Will try the drop-in you suggested.

As of version 5.2.5 I am unable to update WordPress with the Router Mode is set to Localhost. I get this error in the WP dashboard when I try to update WP:

Downloading update from https://downloads.wordpress.org/release/wordpress-5.3.2-new-bundled.zip…

Download failed.: cURL error 28: Operation timed out after 300000 milliseconds with 7388777 out of 13283053 bytes received

Installation Failed

I can’t speak for MacOS users, but for Windows users Local Lightning is extremely buggy. I can think of about 8 major bugs that basically make it unusable at the moment. Add this bug to the list.

1 Like