Updating domain name to .local SSL not verifying now

Due to Chrome 63 forcing HTTPS on .dev - https://laravel-news.com/chrome-63-now-forces-dev-domains-https - I needed to update my domain name to a .local domain. Site is a WooCommerce site and is forcing HTTPS so I need SSL verification.

Getting invalid certificate errors - # SEC_ERROR_UNKNOWN_ISSUER

Any clue on how I can fix this? I tried removing the certs in ~/Library/Application Support/Local by Flywheel/routes but no dice.

Hi Cole,

Since you’ve already changed the site domain, I’d try this:

  1. Restart the site that you’re having this issue on
  2. If the site is already selected in Local, click off of it onto another site and then back onto it. This will force some of the information on the site panel to refresh including the site’s certificate fingerprint that Local looks for in the system keychain.
  3. Go to “SSL” tab and click “Trust”
  4. Press Cmd + Shift + R in Chrome to do a hard refresh. This should force Chrome to look up the certificate in the keychain to see if it’s trusted.

Thanks @clay!

#2 fixed the issue for me. So simple :stuck_out_tongue:

I did all of the above and still have the error in Chrome that the SSL is not trusted. Everything was working fine until I went from .dev to .local. Using local version 2.2.4 and chrome 65.


Are you still experiencing this issue?

Have you tried restarting your browser? Sometimes that’s what it takes to load in the newly trusted certificate.