Upload folder is not writable [OSX 13.2.1 (22D68)]

Issue Summary

Php cant write to any folder, esp uploads.

One or two sentence summary of the issue.

I’ve tried

sudo chown -R {myuser}:wheel ./uploads

and ive tried it with the group _httpd _www everyone

I’ve also set the perms to be full to everyone…

sudo chmod -R uga+rwx ./uploads

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular? All sites, i’ve tried with nginx and apache

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser? yes


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

Nothing in the logs about this

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    OSX 13.2.1 (22D68)

  • Attach the Local Log. See this Help Doc for instructions on how to do so:
    local-lightning.log (38.0 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Help please! Anywhere else I can ask for help?

Hi @timatron

Did this happen suddenly or have you never been able to get write permissions for these sites? Does doing a full restart of your machine make any difference?

This is the error I see in your log which seems to indicate that the user directory doesn’t exist:

Error: ENOENT: no such file or directory, stat '/Users/tschwartz/thedailyupside/tdu-local/app/sql/local.sql.tmp

I’ve never been able to write to filesystem from within Local (wp / php). This has happened since install and I haven’t been able to fix it yet. New installs and restarts included.

the sql.tmp error was about me moving around a database file, not about the writability. mysql functions just fine


I see another user here that had a similar issue and provided some steps that helped them resolve if you’d like to try this:

Yeap, I saw that and checked that as well, it didnt work.

Can you tell me does apache or nginx run as the wheel group with Local? Or maybe can you tell me what user/group it’s supposed to run as?


Hi @timatron

Rewinding here a little bit. You mentioned that you’re able to make a new site and access it in a browser correct? So is there something else specifically you’re trying to do during development where this is blocking your workflow?

Hey Nick,

Yeah I just can’t upload new images :slight_smile:

Which i’m ofc working around right now, but longterm will need for dev purposes.


Hi @timatron

Are you unable to add them from the WordPress admin or is there somewhere else it’s giving you the permission error? What are you using as a workaround?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.