Can't upload images in any of my local projects

What issue or error are you experiencing?

Hi,

I’m running about 10 local environments of Wordpress (with Divi theme). Never had any issues. And now I encounter the problem that I can’t upload a image file in Wordpress. When I try I get the message: Unable to create directory uploads/2024/05. Is its parent directory writable by the server?"

Well, I’ve set the rights of everything in the “Local sites” folder to “Read & Write”. But still no luck. I even tried creating the folder myself, but with nu success ether.

Later discovered that it was nog only with my latest project, but also all my other projects that I run with Local. And with all my other projects i’m 100% sure it worked before.

Can someone pinpoint me in the right direction? Thanks in advance

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version: Version 9.0.3+6684

  • **Operating System (OS) and OS version: Mac OS Monterey 12.7 5
    local-lightning.log (171.7 KB)
    **


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Romana

You might need to check the individual folders and files to see what the permissions look like and see if something changed. This might help:

Thanks for your answer. I’ve reset the file permissions again. Now with the seperate ones for files (644) and folders (755). But still no luck.

Also tested again on my live site if I’m able to upload images there. But I can. Just not when I transferred them to Local… And tried to get a new copy of my livesite and import it to Local. But also no luck…

If you just create a new, blank site in Local and try to upload an image there does that work? Or same issue?

Do you have any antivirus, security, or firewall applications that could be blocking Local?

I don’t have any firewalls. But when i’m opening a blank project I am able to upload images.

Do any of your previously built sites utilize any security plugins?

Wp 2FA (2 factor authentfication),
Limit login attempts.

I disabled Wp2fa after trying to login locally by underscoring the map of the plugin.

I have no other plug-ins firewall of security wise…

Complete list of plug-ins (other then stated above):
A3 lazy load
Better search and replace
Divi Supreme pro
Duplicator
Enhanced media library
Manage wp worker
Newsletter, SMTP, Email marketing and Subscribe forms by Brevo
Rankmath seo

As a test can you try disabling all of the plugins and then see if the image upload works again? If that doesn’t work try switching to a default theme and see if that works.