Uploading error: This file is not allowed for security reasons

What issue or error are you experiencing?

I can’t upload any media(photos, videos, etc) It says: This file is not allowed for security reasons

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:
    Version 8.2.1+6583

  • Operating System (OS) and OS version:
    Windows 11 Pro

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-lightning.log (123.7 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hello @foxeslink - welcome to the Local community + thank you for your question! :wave:

Are you by chance using Elementor on this site?

If you are using Elementor, it looks like you can enable something called “unfiltered uploads” from your advanced settings to allow you to upload files that are currently blocked by the plugin.

I may suggest you take a look at this: Settings » Elementor

If you’re not using Elementor we’ll want to dig a little deeper.



1 Like


Yes I’m using it, but unfortunately that was already enabled. I tried to disable and enable again but got the same issue. It’s strange because a couple days ago I could upload with any issues

Hello there, I have same issue can’t upload any file since yesterday

Probably it’s a local problem or maybe an elementor issue

i found solution,go install older version,this one got bug.

1 Like

You mean local or elementor?

elementor install older version

Hi @foxeslink -

Please let us know if downgrading Elementor fixes this problem for you.

Thank you!



For some reason going back to any other version of elementor is not solving it for me. My unfiltered is Enabled. Any other ways to fix? I want to build a site for a project but it is saying this file is not allowed for security reasons

Turning the Elementor back is only making the editor unable to be used.

Hi @anthonyfranck

If it’s purely an Elementor issue there isn’t much we can do. Could you provide some more details to help us take a further look?

  • What is your OS?

  • What version of Local are you on?

  • Please attach a copy of your Local Logs

I am on Windows 10 Home, Local Version Version 8.2.1+6583

I can try a different laptop or a Mac. Is this tool intended only for mac OS?

Hi @anthonyfranck -

Local is not only for mac. You can find the releases for your OS here:


I have the same issue. First Elementor support told me to edit the wp-config.php file which I had already. Then to told me to contact my host.

1 Like

Well, my website is live now, I dont have the problem any more but there’s a way around to trick the issue. You can go to media-add media, on the WordPress dashboard. Then you can select the media you Uploaded on elementor.



I’m using windows 10 + localwp Version 8.2.1+6583
and same problem here… after last update from wplocal and elementor plugin 3.19.2
I cannot upload jpg, png, or any other file using elementor editor because I got the
message: when I’m using elementor desing and upload files.
This file is not allowed for security reasons
If I upload outside elementor the upload worked…but this is a bad solution.
If someone could help, it will help a lot because I’m in troubles with this problem


Thats bad, im also having this issue after the update and cant upload any type of file, not even .png or .jpg.
I also downgraded elementor, the other plugins i was using and even Local itself but nothing works in the new sites i create.
funny enough, in the older projects i have everything is working accordingly.

I tried plugins to manage and give access to all types of files to be uploaded, put a code on wp-config.php file, but it doesnt work as well.

the only method that works is adding media directly from the dashboard, but thats not practical.

my only resources of studying are the old sites hosted on local.

hope this gets fixed soon


Same here. Older sites are ok, but the last couple I have added I get this error. I can upload from media section of WP but not from within Elementor directly. None of the fixes I have seen online have worked.


I am also having this issue!

I cannot upload from anywhere in elementor, even with the unfiltered setting enabled (and I am uploading .jpeg, .jpg, and .png.

This is my first time using ANY of WPEngine’s products and as cool as LocalWP looks, this error makes it entirely useless to me.

Also, it appears that there are multiple people who have been using local WP for a while who are having the issue.

@sambrockway Please coordinate with the WPEngine team and look into this soon! (From the comments you can see it’s clearly NOT an Elementor error, and NOT an OS error)

2 Days back, I switched to LOCAL. (Earlier I was using Xampp). I liked LOCAL due to its ease of use, until I got stuck with this same problem as described in the thread.

Tried all fixes,

  • Added permitted file types by changing WordPress Multisite settings.
  • Modified approved file types using a plugin.
  • Used the upload_mimes filter by editing my theme’s functions.php file.
  • Allowed unfiltered uploads in the wp-config.php file.
  • Manually uploaded the to the wp-content folder.
  • Enabled Unfiltered Uploads option in Elementor.

STILL NO USE. I get the same error “Sorry, This File Type Is Not Permitted for Security Reasons”

I am running LOCAL v8.3.1+6650 (with Apache, PHP 8.3, MySQL 8.0.16) on Win 11 Pro 23H2 (Build:22631.2861) x64 / 8GB / 1TB HDD

Now I have switched back to XAMPP and all works fine there. Please fix the issue.

1 Like