WebSite not working after updating to Local v6.5 on macOS

Issue Summary

One or two sentence summary of the issue.

Once I updated to a newer local version, I can no longer open the site nor get to the admin area as it shows an error

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

This happens for all sites

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

I am not able to create a new plain WordPress site in local and access it in the browser


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

If I click open site or WP admin it takes me to this screen:

If I try and create a new site after going through the steps and before it creates it, I get this error:

System Details

  • Which version of Local is being used?

Version 6.5.2+6204

  • What Operating System (OS) and OS version is being used?
    • For example: macOS Catalina or Windows 10 Professional

macOS High Sierra Version 10.13.6 (14.1 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Im getting the same issue. I hope someone actually replies to this as I posted mine 4 days ago with no response.

Same here. I have the same errors as the screenshot posted by the OP. In there is a mention of a file “which was built for macOS 11.0”, so I’m assuming that anything above Local 6.4.3 will not run on anything less than macOS 11. Unfortunately, it seems that the update reminder doesn’t know this, and allows the update to 6.5.x or 6.6.x. It should ideally list those updates as incompatible if you are running macOS <11.

Similarly, if you completely wipe Local from your system and do a fresh install of 6.5.1, 6.5.2 or 6.6.0, it will fail. Again, ideally the executable should have a minimum OS version of 11, and macOS will then show it as unavailable to be run.

Perhaps it’s not possible on this particular app for the developers to prevent updates/installs on an incompatible OS - in which case maybe an announcement and a clear system requirements statement would be good - similar to the announcement for the update to 6.4.3 which explained about code signing. FWIW I can’t actually see a OS requirement in the system requirements - all it seems to say is disk space and memory.

The only workaround I have is to completely erase the install of 6.5.x or 6.6.x and reinstall 6.4.3, but then you will lose your Add-ons and probably be unable to reinstall them, as many of them require 6.5.2 and above (unlike the main app itself, where all releases are still on the LocalWP website, I don’t think previous versions of add-ons are available).

I also deleted previous Local installs and installed Local v6.4.3 but I get the same results! It still wont work.

FWIW I have found that, depending on how the app crashes and/or how an install fails, the Application Support files are regenerated on reboot, even with the app not installed. It might be worth looking to see if there’s an incomplete ~/Library/Application Support/Local folder there. You can tell it’s incomplete if it only contains a folder called ‘run’, which in turn contains a folder called ‘router’, and you probably won’t be able to drill down any further. Even if you delete that folder, it’ll come back after a reboot. Try changing permissions on the ~/Library/Application Support/Local to include yourself and apply it to enclosed folders, then delete it and empty the trash. Don’t reboot. Then download a new copy of 6.4.3 (this is important, as I think it triggers GateKeeper to run the integrity checks again) and install that.

Hi @RandyG,

We recently did some work to update the PHP versions available in Local, including shipping 8.1.9 and including patch bumps for 7.4 and 8.0. We compile those binaries ourselves, and part of that process is bundling .dylib files to (hopefully) ensure system compatibility. In this case, it looks like one of the dylibs we are shipping, libpcre2-8.0.dylib, was compiled for newer macOS versions than 10.13, so your system’s libSystem.B.dylib (which we don’t ship) can’t use it.

What that means for you is that you probably won’t be able to use Local to create sites with PHP 7.4.30, 8.0.22, or 8.1.9 on your system right out of the box without upgrading your OS. Unfortunately, the best option may be downgrading to Local 6.4.3 and using PHP 7.4.1 or 8.0.0 (I believe those versions are available in that version of Local).

We bundle PHP 8.1.9 with the Local App, as you can see in that error message, so I don’t think you’ll be able to easily replace the offending libpcre2-8.0.dylib with a compatible version from your own system. However, that could be a potential workaround if you see this same error for PHP versions 7.4.30 or 8.0.22 - that file would potentially live in your usr/lib directory and could be copied to the path specified in the error message.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.