Local Community

Websites all broken after update

Issue Summary

I posted this issue months ago and it was ignored.
I updated Local and now roughly 18 of my 23 websites don’t work.

If you start the site and click WP Admin are simply greeted with a ‘Browser can’t connect to server issue’.
If you click Open Site you get the website with no CSS styling so just massive svg icons etc.

Why has the issue not been resolved yet? The is a catastrophic all website software issue.

Luckily I have backups of every site and I’m in the process of re-importing them all but it’s completely unacceptable.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • All existing local sites.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

  • Yes new sites work.

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?
    Version 6.6.0+6231

  • What Operating System (OS) and OS version is being used?

    • macOS Monterey

Hi @brendanfostertdd - thanks for using Local!

I believe I found your old thread (and sorry it got missed) - you’re referring to this one from December 1st, correct? All Local Sites stoped working and show error on Wordpress Version

There were several other threads I saw you commenting on, but those were all specific to users on macOS Mojave or High Sierra. Thankfully, you’re on macOS Monterey so that shouldn’t be an issue!

Based on what you’re describing, I don’t know of other users reporting similar issues re: WP Admin and no CSS on the site. Can you share a copy of your Local log (Retrieving Local’s Log File - Local) and some screenshots of what you’re seeing? I want to make sure we’re looking in the right place when we dig in.

Hey Austin,
Im genuinely surprised someone got back to me. I’de honestly given up.

Attached are some screenshots of what happens when I turn on one of the effected sites.
Also attached is local log file.



local-logs.zip (40.9 KB)

Thanks for sharing those logs! There are a few errors in there we can take a look at, but nothing that would have the effect you’re seeing. There were some permissions errors with Live Links (most likely due to a firewall?) and a JSON parsing error while importing a new site.

Are you using site domain router mode (mysite.local) or localhost router mode (localhost:10001) in Local? If you’re not sure, you can check in Preferences > Advanced. My hunch is that something in there isn’t playing nicely.

You mentioned once you reimport the sites, they work again?

Hi Austin,

I don’t have any extra firewall setup other than my Macs normal one.

All the sites that don’t work were previously working and then one day they all failed with the same issue.

Using Router Mode localhost.

Yes I had export backups of all these websites.
If I import the site again as a new site it works.

If I setup a new site they also work.

I guess this got put in the too hard basket again.
Awesome.

You might as-well just say.

“Yeh look we stuffed up, if you don’t have backup/exports of those sites you are screwed, we can’t help you. If you do have backups, you are just going to have to make brand new installs of the 25+ sites you have again. Thanks for using Local.”

Hey @brendanfostertdd - I’m genuinely sorry I missed your reply here. Like I said, we were looking into the logs you shared, but I didn’t see anything specifically that described the problem you’re having.

I’m not sure if you have this problem solved already - if you’d like to keep troubleshooting, I’m happy to do so. It looks like there is a mismatch somewhere; your screenshot shows you’re in localhost mode, but when you open the site, you’re navigating to laneway-the-label.local. I would expect that to be localhost:10043 based on the error message from Safari - it is trying to redirect to localhost:10043, but can’t because it dead ends at the site domain that doesn’t exist.

Were you hitting ‘Open Site’ in Local to open the site in Safari, or did you navigate directly to it in your browser? If you navigate directly to localhost:10043, my assumption is the site would launch. Or, if you switched Local back to site domain mode, I assume you would get a prompt to update your etc/hosts file with a red Fix It button, and the site would work again and live at the custom site domain.

When you hit Open Site in Local, it references the URL stored in the WordPress database for the site. If the above troubleshooting didn’t solve it, the issue would be in the database - somehow that URL wasn’t updated when the site transitioned from localhost to site domain mode or vice versa.

Hopefully this helps; if you’ve already solved this and want to move on, I understand.