Where Can I Find this File? (Needed for using MainWP)

I’m trying to set up a MainWP site on local in order to push all updates to the dev sites at once (plugins, core updates, etc) and at setup I get this message for which I’m pretty sure the default path is wrong.

Where can I find this openssl.cnf file? Where does LbF install it?

ALSO, will my child sites need to be in the “started” state in order to be detected and synched by the MainWP dashboard (parent site)?

@clay would you be able to assist on this please?


/usr/lib/ssl/openssl.cnf is the default location for both Custom and Preferred Environments.

Here’s how you can get this value in the future in case it changes:

  1. Click on the i beside the Local site’s PHP version to open a PHP info page
  2. Scroll to the openssl section
  3. Check the value of Openssl default config

Thanks - but what is the full path to this file? I can’t seem to find it in the individual sites’ directories… I must not be looking in the right location…

The file is inside the container and isn’t exposed like the normal site files are. If you type in that path, MainWP will be able to see it.

Considering the first step on MainWP is mentioning “Windows Localhost”, I think something isn’t right there since all Local containers run Linux. What happens if you skip that step?

Maybe that’s because at Step 1 they have us choose between a remote server and a local server. See screenshot. Should I choose “Web host” instead of “Localhost”? Please advise…

I just tested the MainWP Dashboard plugin along with a site running the MainWP Child plugin.

I selected “Localhost” and then “Linux” since the Local sites are running inside of a Linux virtual machine. This answer will be the same whether you’re running Local on macOS or Windows.

1 Like

Fantastic! Meanwhile, I had opted to try your “SKIP THIS STEP” suggestion and that also worked. Seems to me that by choosing that option, it was smart enough to configure itself properly to a Linux based localhost. I also didn’t have to specify the file/location mentioned in first post. Maybe they should call SKIP THIS STEP “Wizard” or something like that!

HOWEVER–> One thing I did notice though was that to add a child site, I had to use the http: nomenclature. Using https it would not find the .local site I specified. Which may not be surprising since all my sites, despite being https once deployed, are all showing as Not Secure on Local.


Glad to hear it!

Gotcha. It’s most likely getting tripped up on the self-signed certificates. Fortunately, we have plans to drastically improve how certificates work in Local :slight_smile:

Maybe I’m missing something… MainWP aside, the moment I change my WordPress site settings from http:// to https:// Chrome gives me the big red exlamation mark in a triangle with " Your connection is not private" - and only option is Go Back to Safety.

So in LOCAL, I went to the SSL tab and clicked TRUST for Certificate. It changed to “TRUSTED” however, it still does not let me into the website. Is this normal? I was almost certain that in the past I had had a green bar prompting me at the top to trust…

Please advise further…

On Windows, you have to restart Chrome in order for the trusted certificate to take effect.

Do you see a Windows UAC/Admin prompt when you click on the “Trust” button?

Yes I remember seeing something about CertUtil.exe to which I answered yes.

SOLUTION Ok, I tried the reverse approach on other sites and it worked. Meaning instead of changing to https in WP first and then clicking TRUST, I did the opposite.

I clicked TRUST for the website and accepted the UAC prompt.
I logged in to the site (not secure version).
I changed http to https in WordPress settings and clicked Save Changes. This logged me out.
I logged back in successfully into the https version of the site.

There was also no need to restart Chrome. The order of doing things though appears to have been critical.

Hi Clay

I’m having the same issue running MainWp through LocalWp on my Mac. I tried the suggestions above but it still hasn’t fixed the issue.

Any other ideas?


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.