Trying To Use MainWP On Local But Keep Getting An Error When Trying To Connect Sites

Hi Folks

I was so glad to find a local host that actually worked on my Mac but I’ve been knocking my head against the wall trying to set up MainWP ( on it. When I try to add a site I get an error.

After talking to MainWP support they told me it wasn’t working because I need to enter the path to openssl.cnf

I’m on a Mac running macOS Catalina and a search for this file gave me 17 different results. Of course I have no idea which (if any) of these is the correct one. I was referred to a thread here that solved the problem for someone else but those instructions haven’t worked for me unfortunately.

I’m not a coder so I’m probably a bit out of my depth here but I would love to be able to use this tool to manage my websites locally.

Any ideas what I can do to solve this?

Appreciate your help.

The path to OpenSSL is in the phpinfo button. With the site active, from Local, click on the “circle I” (info) icon next to the php version. It will display the php info page. Somewhere on that page you will see an entry for OpenSSL. There will be a file path. Use that one.

Sorry I’m on my iPad, no images for help.

I had this issue too. I had to got back to the MainWP setup wizard. I think I had to select localhost > Windows even though I was on a Mac.

Hey @afragen

Appreciate the quick response. I actually found those very same instructions before and it didn’t work. I just tried again for good measure but same result.

Could it be that I’m entering it incorrectly? In the OpenSSL section its lists the path as /usr/local/etc/openssl@1.1/openssl.cnf

That’s exactly what I entered. Should I have changed the syntax? Like put “Mac HD” somewhere in there? (This is all new to me)


You might want to enter that path In the Go to Folder command from the Finder and see if it’s correct. At least it should be close.

Otherwise sorry. But I can say it works cause I’m doing it.

Thanks for the suggestion. Then search actually shed a little light on the subject.

The usr/local folder shows up as empty which I’m guessing either means the folder actually is empty or the files are hidden?

I think I’ll just copy the path of each of the 17 results I find when I do a search and plug them in one by one. If that doesn’t work I’ll call it a defeat and move on.

Appreciate the help :slight_smile:


You’re not gonna believe this. The first path I tried worked!

I looked through the paths one by one and most of them looked like they were associated with Wordpress plugins but then I came across one that looked more like the examples I’d seen in one of my Google searches and it worked.

For anyone having the same issue here are the steps I followed:

  1. Install MainWP on the Wordpress installation running on LocalWP using all default settings
  2. In the MainWP dashboard navigate to Settings > MainWP Tools
  3. Click the " Quick Setup Wizard" button
  4. Click “Let’s Go” and select “Localhost” and “Windows” radio buttons. (Yes, weird even though I’m on a Mac but this is what works).
  5. Enter the following path into the box that opens up once you select “Windows”
  6. Click “Continue” to ensure the path you entered is saved

Then it’s just a matter of either completing the wizard to add your first site or exiting the wizard and adding a website by clicking the “New Site” button at the top right of every page in the MainWP dashboard.

Oh and to find the path of the files I was looking at… open a Finder window and make sure “Show Path Bar” is enabled in the “View” menu. For each file you single-click on in the Finder you’ll see a path at the bottom of the Finder window.

Use either Ctrl-Click, 2 finger tap or Right-Click on the file name in the path to reveal the option to “Copy FILENAME as Pathname”. See attached image below…

Finding the openssl file


I believe you need to search for /usr/local/. The leading slash is important. I believe the /private seems to be unnecessary but is more correct.

I’m glad you got it figured out and thanks for completely documenting this.

1 Like

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.