Windows 1.4.4 - Local Router Error

Hi Clay and Local team,

I know there are some posts with this problem now.
I have the same i have windows 10 with local 1.4.4
I did try the following :

  • Updating virtualbox manually
  • Reinstall of local

I can get it to work when i reinstall local and then import an export i made before.
Then it works for the time i can stop and start the install and it still works.
Now i had another i did the same and as soon as it updated the WP-CLI and i got the note in local
I get the Local Router Error.

I can send my log if you want.

Hope this get solved soon cause this really puts a hold on productivity :slight_smile:

Not sure if this works for everyone, and not sure if it works on 1.4.4 (as I haven’t updated due to the reports of it just refusing to work).

But on 1.4.3 I noticed that if I stop each site individually it breaks, but if I use the Stop All button (even if it’s just a website) they can be restarted without problems.

I can start sites individually without a problem, but I must always use the Stop All button to get it to work again in my next session.

Hopefully all these errors get ironed out soon because when Local is working, it’s just so good.

1 Like

I tried what you said but it didn’t work and still gave the error.

I got one site running it worked i did stop all
I enabled it individually it again said WP-CLI was out of date and updated…
Again local router error.

I stopped and started again it again says updating WP-CLI so maybe this part is stuck and doesn’t let the site connect?

Probably some error specific to 1.4.4

At this point I may suggest reverting if possible to 1.4.3, at least for me it seems more stable than 1.4.4

True , i only can get it to work with only one site installed or if i import a site work on it when i am done export it again, stop local and later import it again and so on.

Also if i revert back to 1.4.3 i can’t do the exports of sites and as i do use this to move from desktop to my mac.

Hope this get fixed soon as it really puts a hold on productivity

Update to version 1.4.5, it fixed the Local Route errors for me and others

I did and it worked perfectly :slight_smile: