Woocommerce installation failed?

Issue Summary

Can’t install wordpress, could not create directory?

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    Created two new sites and same issue

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Yes can access but can’t install woocommerce


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    Windows 10

Installation failed: Could not create directory. woocommerce/packages/woocommerce-blocks/assets/js/blocks/cart-checkout/checkout-i2/inner-blocks/checkout-shipping-methods-block/no-shipping-placeholder

Hey @Jaimster08 , Welcome to the Local Community Forums!

Usually issues that relate to permissions, like not being able to create a directory, are related to some sort of security setting or antivirus.

For the sites that are having this issue, is it the exact same error, or are there different errors?

Can you also describe in a little more detail about how the plugin is being installed? If you have a screenshot of where you are seeing that error that would be helpful too!


I’ve installed woocommerce before on previous sites using the standard ‘Add plugins’ area. So having a permissions issue is weird. Ive upgraded local and also installed antivirus since so I’ve just tried disabling it although not luck. Seeing error under the plugin when it’s trying to install, just before the activate button comes up

Hi, I have the same problem. I installed localwp and when i tried to install woocommerce plugin appears the warning.
What can i do?
Thanks for your guide

It’s hard to know why WordPress doesn’t have the permissions to write to that folder.

Within the Windows File explorer, can you navigate to where that folder is located and see what the permissions of the folder are? You can do that by right-clicking on the folder and selecting “Properties.”

I have the exact same issue. I tried to disable antivirus. Made no difference.

The starting folder (woocommerce) was not even created by the installer. I created the entire missing folder path manually. Made no difference.

I downloaded the installer and tried to upload and install it that way, made no difference.

This is a brand new install of Local that I downloaded and installed today. Everything else works fine.

Any ideas?

@Jaimster08 I think I found the fix. The PHP version that Local defaulted to on my PC was set to 7.3.5 I changed it to 8.0.0 and Woocommerce installed without an issue.

Hope this works for you too!!

1 Like

Thanks a lot @Jaimster08 I did Exactly what you suggest and it works. Thaks a lot!!!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.