WordPress URL settings error

Issue Summary

Warning shows.

Troubleshooting Questions

It happens intermittently can be ignored. I can’t figure out it it actually causes a problem


Occasionally pops up if more than one site is running.

System Details

  • Which version of Local is being used?
    Local Beta 5.9.7

  • What Operating System (OS) and OS version is being used?
    macOS Big Sur 11.1 on M1 Mac

It seems as if I can safely ignore this warning as it doesn’t seem to interfere with function. Stopping and restarting the site in question can make the warning disappear and the ‘Fix It’ button doesn’t seem to do anything.

To help clarify what you’re seeing in that banner – basically, Local is saying:

The domain that I’m seeing when I query the database doesn’t match what you told me it should be under the Site Domain field in Local.

Usually this is due to something like changing the Router Mode from Site Domains to localhost. In this case, Local will think that the domain is localhost:10005, but when it queries the db, it gets example.local. When you click the “Fix it” button, Local will run a search/replace against the DB to update the url to be what is set within Local.

That’s the most common reason to get the banneer, but I suppose there could be other reasons that Local thinks that the domain within the db is different from what is set within the Local app.

The one other time I’ve seen something similar is when a “force https” plugin was trying to redirect all requests to WP to be done over HTTPS. Because that plugin didn’t account for wpcli, anytime Local tried to get the domain from the DB, it would be than what Local was asking for, even though the value that was in the db was correct.

From the screenshot, you appear to be running an alpha build of WordPress. If you open a terminal and try to issue a command, do you get any errors? There might be differences in output if you skip plugins as well:

wp option get siteurl
wp option get siteurl --skip-plugins --skip-themes

Well I’m only using Site Domains and not using anything that forces https.

I’ll check with the rest out and report back when I have data.

Yes I’m running WP trunk. :nerd_face:

1 Like

Running both of the above commands gives me the same result.

$ http://lightning.test

I do get an error in the response that is directly related to Local setting the WP_ENVIRONMENT_TYPE constant within the application. I really wish you would remove that setting. I develop plugins that set that constant in the wp-config.php and I get an PHP error for it being defined already.

This is happening to me too, very annoying.
It is always asking to Fix it banner bar and when I click fix it, this changes the URL to example localhost:10002. The .local does not work anymore.

When I check the db wp options the url are changed, then I change it back to example site.local but then after a while again it promps me to “Fix it” again.
There is a bug guys that needs to be fixed.
Any solutions please let me know.

Since Local’s prompting you to change to a localhost url – Do you have Router Mode set to localhost? You can find that option under “Preferences > Advanced > Router Mode”

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.